Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 147345 - Assertion (***) at probe_partition_for_geom() failed.
Assertion (***) at probe_partition_for_geom() failed.
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 10:23 EST by Andrea Assorgia
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Assorgia 2005-02-07 10:23:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
* parted exception: Bug: Assertion (heads < 256) at disk_dos.c:486 in 
function probe_partition_for_geom() failed.
* parted exception: Bug: Assertion ((C * heads + H) * sectors + S == 
A) at disk_dos.c:495 in function probe_partition_for_geom() failed.

The installer produces lots of these bugs during the whole 
configuration before the installation begins.

If you keep ignoring (or canceling) them, you eventually end up with 
an invitation to iussue a bug (as I'm doing now) and exiting to text 
console. Needless to say the installation doesn't even start.

I'm trying to install on slave HD within a 3 discs system, configured 
these way
hda1 10 GB - Windows XP
hda2 30 GB - VFat32
hdb1 1 GB - Linux swap
hdb2 19 GB - Linux ext3
Hdd1 40 GB - Vfat32


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot your PC with FD3 disk 1 in your Cdrom reader
2. Follow all the preliminary steps (like choosing language and 
configuring your network.
3. See how it crashes
    

Actual Results:  The installations didn't even start.

Expected Results:  The installation should have started

Additional info:
Comment 1 Jeremy Katz 2005-02-07 10:25:02 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.