Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1473452 - Rebase pki-core to latest upstream 10.5.x release (RHEL)
Rebase pki-core to latest upstream 10.5.x release (RHEL)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.5
Assigned To: Matthew Harmsen
Asha Akkiangady
Aneta Šteflová Petrová
: Rebase
: 1471298 (view as bug list)
Depends On:
Blocks: 1472344 1477926 1490412
  Show dependency treegraph
 
Reported: 2017-07-20 19:02 EDT by Nathan Kinder
Modified: 2018-04-10 13:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: pki-core-10.5.1-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
*pki-core* rebased to version 10.5.1 The *pki-core* packages have been upgraded to upstream version 10.5.1, which provides a number of bug fixes and enhancements over the previous version. Notably, this update addresses the requirements for the Common Criteria Protection Profile for Certification Authorities Version 2.1.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 13:00:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0925 None None None 2018-04-10 13:01 EDT

  None (edit)
Description Nathan Kinder 2017-07-20 19:02:13 EDT
Dogtag 10.4.x updates are designed to address critical bugfixes and to address any Common Criteria requirements that come up for RHCS.  We should rebase pki-core in RHEL 7.5 to the latest 10.4.x upstream release (exact number TBD) to satisfy Common Criteria requirements.
Comment 2 Matthew Harmsen 2017-07-31 18:15:36 EDT
*** Bug 1471298 has been marked as a duplicate of this bug. ***
Comment 6 Sumedh Sidhaye 2017-12-07 01:27:25 EST
Build details:

[root@pki1 ~]# rpm -qil pki-core
package pki-core is not installed
[root@pki1 ~]# rpm -qil pki-base
Name        : pki-base
Version     : 10.5.1
Release     : 4.el7
Architecture: noarch
Install Date: Thursday 07 December 2017 09:56:36 AM IST
Group       : System Environment/Base
Size        : 2096050
License     : GPLv2
Signature   : RSA/SHA256, Wednesday 29 November 2017 09:03:08 AM IST, Key ID 199e2f91fd431d51
Source RPM  : pki-core-10.5.1-4.el7.src.rpm
Build Date  : Wednesday 29 November 2017 07:47:20 AM IST
Build Host  : ppc-035.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://pki.fedoraproject.org/
Summary     : Certificate System - PKI Framework
Description :
The PKI Framework contains the common and client libraries and utilities
written in Python.  This package is a part of the PKI Core used by the
Certificate System.
Comment 7 Sumedh Sidhaye 2017-12-07 09:52:32 EST
Package installation succeeded without any problems and basic functionality working as expected. Hence, marking this Bug verified.
Comment 11 errata-xmlrpc 2018-04-10 13:00:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0925

Note You need to log in before you can comment on or make changes to this bug.