Bug 1473485 - libreoffice base crashes when using mysql-connector-java to connect to MySQL database
libreoffice base crashes when using mysql-connector-java to connect to MySQL ...
Status: CLOSED DUPLICATE of bug 1468436
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
26
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 21:19 EDT by John Fattaruso
Modified: 2017-07-21 05:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 05:33:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Fattaruso 2017-07-20 21:19:36 EDT
Description of problem:
Any use of the mysql-connector-java in libreoffice base crashes libreoffice.

Version-Release number of selected component (if applicable):
Two different systems show the same bug:
  Fedora 26
libreoffice-base-5.3.4.2-3.fc26.i686
mysql-connector-java-5.1.38-4.fc26.noarch
java-1.8.0-openjdk-1.8.0.131-7.b12.fc26.i686
  Fedora 25
libreoffice-base-5.2.7.2-5.fc25.i686
mysql-connector-java-5.1.38-3.fc24.noarch
java-1.8.0-openjdk-1.8.0.131-1.b12.fc25.i686

How reproducible:
Every time

Steps to Reproduce:

1. Open libreoffice base
2. After registering class path /usr/share/java/mysql-connector-java.jar click "Test Class" button

  --or--

1. Open libreoffice base
2. Select "Connect to an existing database"
3. Select "JDBC" for a MySQL database
4. Attempt to store a .odb file

  --or--

1. Open libreoffice base
2. Attempt to open a previously stored .odb file, click on "Tables" and enter the access password

Actual results:

Libreoffice crashes.

Expected results:

MySQL database tables opened for editing

Additional info:

I've had the mysql-connector-java connection working fine for many Fedora systems over several years, and it was working fine in my Fedora 25 system fine up until about three months ago, when this crashing started after using dnf to accept package upgrades. Another system I recently upgraded from Fedora 24 to 26 now shows the same bug.
Comment 1 Michael Stahl 2017-07-21 05:33:50 EDT
arch is i686, crash on first JVM use and it worked fine until quite recently
=> pretty convinced this is the kernel "Stack Clash" fix breaking the JVM

workaround: downgrade kernel or use x86_64 packages which aren't impacted by the problem

*** This bug has been marked as a duplicate of bug 1468436 ***

Note You need to log in before you can comment on or make changes to this bug.