Bug 1473512 - Pod chart display was out of the border on overviewpage in IE 11
Pod chart display was out of the border on overviewpage in IE 11
Status: VERIFIED
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ---
: 3.7.0
Assigned To: Robb Hamilton
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 00:17 EDT by xipang
Modified: 2017-10-09 03:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A known bug in Internet Explorer resulted in the layout of pod charts overflowing their containers on the overview page. Consequence: As a result, the pod charts looked mis-aligned in the UI. Fix: The fix involved increasing the specificity on some CSS declarations so that they only apply when they are needed, which is during a deployment when the pod charts are being animated. Result: The pod charts appear correctly aligned in Internet Explorer.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
out of border (115.46 KB, image/png)
2017-07-21 00:17 EDT, xipang
no flags Details

  None (edit)
Description xipang 2017-07-21 00:17:40 EDT
Created attachment 1302126 [details]
out of border

Description of problem:
Pod chart display was out of the border on overviewpage in IE 11,especially when browser is maximized.

Version-Release number of selected component (if applicable):
oc v3.6.153
kubernetes v1.6.1+5115d708d7

How reproducible:
Always

Steps to Reproduce:
1.Login web console, create a application(eg.ruby)
2.Click " > " expande button , check pod chart display when change browser zoom view to 100%

Actual results:
2.Pod chart dispiay was out of the border 

Expected results:
2.Pod chart display normally

Additional info:
Comment 1 Robb Hamilton 2017-07-21 14:44:56 EDT
PR to fix: https://github.com/openshift/origin-web-console/pull/1867
Comment 3 yapei 2017-10-09 03:27:22 EDT
Checked on v3.7.0-0.143.1

The display issue on Overview page has been fixed

Move to VERIFIED

Note You need to log in before you can comment on or make changes to this bug.