Bug 1473577 - slapi-nis should use requests to SSSD with ability to cancel them with a timeout
Summary: slapi-nis should use requests to SSSD with ability to cancel them with a timeout
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: slapi-nis   
(Show other bugs)
Version: 7.5
Hardware: Unspecified Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Alexander Bokovoy
QA Contact: ipa-qe
Aneta Šteflová Petrová
URL:
Whiteboard:
Keywords:
Depends On: 1473571
Blocks: 1420851 1467835 1477926 1472344 1490412
TreeView+ depends on / blocked
 
Reported: 2017-07-21 08:03 UTC by Alexander Bokovoy
Modified: 2018-04-10 18:29 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
See the Doc Text in https://bugzilla.redhat.com/show_bug.cgi?id=1415162
Story Points: ---
Clone Of: 1415162
Environment:
Last Closed: 2018-04-10 18:28:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0989 None None None 2018-04-10 18:29 UTC

Comment 2 Alexander Bokovoy 2017-07-21 08:12:03 UTC
This is a slapi-nis bug to use new timeout/cancellable API from SSSD when bug 1473571 is fixed.

Comment 18 Nikhil Dehadrai 2017-12-18 09:20:49 UTC
IPA-server: ipa-server-4.5.4-7.el7.x86_64
SSSD version: sssd-1.16.0-14.el7.x86_64

Verified the bug on the basis of below observations:
1. Verified that the sanity test run for ADtrust runs successfully.
2. Verified that following commands runs successfully:
 # setup IPA master with latest version , configure ad-trust with slapi-nis option enabled.

[root@auto-hv-01-guest03 ~]# ipa trust-find ipaad2016.test
---------------
1 trust matched
---------------
  Realm name: ipaad2016.test
  Domain NetBIOS name: IPAAD2016
  Domain Security Identifier: S-1-5-21-813110839-3732285123-1597101681
  Trust type: Active Directory domain
----------------------------
Number of entries returned 1
----------------------------
[root@auto-hv-01-guest03 ~]# sleep 60
[root@auto-hv-01-guest03 ~]# id administrator@ipaad2016.test
uid=1577600500(administrator@ipaad2016.test) gid=1577600500(administrator@ipaad2016.test) groups=1577600500(administrator@ipaad2016.test),1577600512(domain admins@ipaad2016.test),1577600520(group policy creator owners@ipaad2016.test),1577600513(domain users@ipaad2016.test),1577600518(schema admins@ipaad2016.test),1577600519(enterprise admins@ipaad2016.test)

[root@auto-hv-01-guest03 ~]# vi /etc/sssd/sssd.conf
[root@auto-hv-01-guest03 ~]# systemctl restart sssd
[root@auto-hv-01-guest03 ~]# kill -STOP $(pidof sssd_be)
[root@auto-hv-01-guest03 ~]# ./sss_nss_getpwnam_timeout_test  test303
Done [5].

Thus on the basis of above observations, marking the bug status to "VERIFIED".

Comment 22 errata-xmlrpc 2018-04-10 18:28:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0989


Note You need to log in before you can comment on or make changes to this bug.