This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1473585 - typo in man heketi-cli
typo in man heketi-cli
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: CNS 3.6
Assigned To: Michael Adam
Prasanth
aos-scalability-36
:
Depends On:
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-21 04:14 EDT by Elvir Kuric
Modified: 2017-10-11 03:07 EDT (History)
10 users (show)

See Also:
Fixed In Version: heketi-5.0.0-7 rhgs-volmanager-docker-5.0.0-9
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 03:07:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github https://github.com/heketi/heketi/issues/823 None None None 2017-08-02 19:25 EDT

  None (edit)
Description Elvir Kuric 2017-07-21 04:14:57 EDT
Description of problem:

man heketi-cli has typo in 

heketi-cli volume create --cluster section.

-- part from man page -- 

 heketi-cli volume create --cluster=<CLUSTER-ID> --disperse-data=<DISPERSION-VALUE> --durability=<TYPE> --name=<VOLUME-NAME> --redundancy=<REDUNDENCY-VALUE> --replica=<REPLICA-
       VALUE> --size=<VOLUME-SIZE> --snapshot-factor=<SNAPSHOT-FACTOR-VALUE>
              Create a GlusterFS volume

                  Options

                      --clusters=""


--- ---- --- 

there is "cluster" and "clusters", valid / working is "clusters"



Version-Release number of selected component (if applicable):
rpm -qa | grep heketi
heketi-5.0.0-2.el7rhgs.x86_64
python-heketi-5.0.0-2.el7rhgs.x86_64
heketi-client-5.0.0-2.el7rhgs.x86_64

How reproducible:
always 

Steps to Reproduce:
try to create volume using 

# heketi-cli volume create --cluster=cluster_id --size=1 

Actual results:

it will fail 

# heketi-cli volume create --cluster=78645dbaa6ce5f16c2162ef6ead4082a --size=1
Error: unknown flag: --cluster

with "clusters" it will work. 


Expected results:
Comment 1 Jan Safranek 2017-07-21 04:22:45 EDT
It's not an OpenShift bug, shifting to Gluster team. Please set the right version, I am really not sure.
Comment 9 Prasanth 2017-09-07 05:22:21 EDT
Verified in man page:

################
   Volume Commands
       heketi-cli volume create --clusters=<CLUSTER-IDS> --disperse-data=<DISPERSION-VALUE> --durability=<TYPE> --name=<VOLUME-NAME> --redundancy=<REDUNDENCY-VALUE> --replica=<REPLICA-
       VALUE> --size=<VOLUME-SIZE> --snapshot-factor=<SNAPSHOT-FACTOR-VALUE>
              Create a GlusterFS volume

                  Options

                      --clusters=""

                         Optional: Comma separated list of cluster ids where this volume
                         must be allocated. If omitted, Heketi will allocate the volume
                         on any of the configured clusters which have the available space.
                         Providing a set of clusters will ensure Heketi allocates storage
                         for this volume only in the clusters specified.
################
Comment 10 errata-xmlrpc 2017-10-11 03:07:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2879

Note You need to log in before you can comment on or make changes to this bug.