This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1473599 - KIBANA_MEMORY_LIMIT: unbound variable
KIBANA_MEMORY_LIMIT: unbound variable
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.5.z
Assigned To: Jeff Cantrill
Xia Zhao
:
Depends On:
Blocks: 1474489
  Show dependency treegraph
 
Reported: 2017-07-21 05:24 EDT by Vladislav Walek
Modified: 2017-08-31 13:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The run.sh script was expecting the var to be defined by the DC but when the pod was restarted it pulled a new image and didn't have the defined var in the DC Consequence: Fix: Default a value for KIBANA_MEMORY_LIMIT Result:
Story Points: ---
Clone Of:
: 1474489 (view as bug list)
Environment:
Last Closed: 2017-08-31 13:00:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladislav Walek 2017-07-21 05:24:47 EDT
Description of problem:

When deploying new image of Kibana, the Kibana fails on error:

/run.sh: line 44: KIBANA_MEMORY_LIMIT: unbound variable

Version-Release number of selected component (if applicable):
OpenShift Container Platfrom 3.5
registry.access.redhat.com/openshift3/logging-kibana:3.5.0-17

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 7 Jeff Cantrill 2017-07-24 14:07:15 EDT
Upstream fix: openshift/origin-aggregated-logging/pull/541
Comment 10 Xia Zhao 2017-08-03 05:34:05 EDT
It's fixed, tested with v3.5 images, kibana is back with log entries presented on UI. Set to verified. 

Test env:
# openshift version
openshift v3.5.5.31.6
kubernetes v1.5.2+43a9be4
etcd 3.1.0
 
Images tested with:
logging-kibana          v3.5                77136c6a8121        7 days ago          342.6 MB
Comment 12 errata-xmlrpc 2017-08-31 13:00:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1828

Note You need to log in before you can comment on or make changes to this bug.