Bug 147360 - Packages which chkconfig --add need to chkconfig --del on removal.
Summary: Packages which chkconfig --add need to chkconfig --del on removal.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-07 16:42 UTC by Derek Anderson
Modified: 2010-01-12 03:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 21:27:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2005-02-07 16:42:24 UTC
Description of problem:
Pretty self explanatory.  Just adding bug for tracking reasons. 
Services affected are clvmd, ccsd, cman, fenced, lock_gulmd, and gfs.
 The result of not chkconfig --del <service> in the preuninstall
scriplet is broken links in the initscripts directories.  It's been
causing me weird upgrade failures.

Version-Release number of selected component (if applicable):
RPMs from 2005-02-01-1120.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chris Feist 2005-02-07 17:01:59 UTC
Changes have been made to the ccs, cman, fence, gulm & GFS packages.

Awaiting confirmation that lvm2-cluster is getting done.

Comment 2 Chris Feist 2005-02-08 19:02:26 UTC
lvm2-cluster has been committed as well.  Fixes should be in the
2-8-05 build.

Comment 3 Derek Anderson 2005-02-09 16:02:35 UTC
Chris,

Looks like ccs was missed:
$ rpm -qp --scripts ccs-0.20-3.i686.rpm
postinstall scriptlet (using /bin/sh):
chkconfig --add ccsd

Also, I do not see updated lvm2 packages in the 2005-02-08-1707 build.

Comment 4 Chris Feist 2005-02-09 16:24:58 UTC
The fix should be in the ccs-0.20-4 rpm.  It didn't get built because
no source code was changed.  (It has been rebuilt now and will be
included in the next tarball.)


I've also requested that the lvm2-cluster is rebuilt with the new
packages.  I'll mark this bug modified once I confirm they have been
rebuilt.


Comment 5 Chris Feist 2005-02-09 20:35:21 UTC
Packages have been built and it looks like the chkconfig --add/--del
is on all the necessary packages.

Comment 6 Derek Anderson 2005-02-09 21:27:34 UTC
OK as of 2005-02-09-1415. 


Note You need to log in before you can comment on or make changes to this bug.