Bug 1473604 - DNS problems in qemu user networking
DNS problems in qemu user networking
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
26
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 05:31 EDT by Jan ONDREJ
Modified: 2017-08-10 02:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-26 01:22:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2017-07-21 05:31:29 EDT
Description of problem:
Currently DNS is completely broken in qemu. Trying to boot Fedora 26 netboot image with.

Version-Release number of selected component (if applicable):
qemu-kvm-2.9.0-1.fc26.1.x86_64
dnsmasq-2.76-3.fc26.x86_64

How reproducible:
always

Steps to Reproduce:
1. qemu-kvm -m 2000 -cdrom Fedora-Server-netinst-x86_64-26-1.5.iso -net user -net nic
2. curl -v http://www.redhat.com/

Actual results:
* Could not resolve host: www.redhat.com
Comment 1 Jan ONDREJ 2017-07-26 01:22:06 EDT
Works well with latest qemu-kvm-2.9.0-3.fc26.x86_64.
Thanks to all.
Comment 2 Cole Robinson 2017-07-26 10:56:12 EDT
(In reply to Jan ONDREJ from comment #1)
> Works well with latest qemu-kvm-2.9.0-3.fc26.x86_64.
> Thanks to all.

Glad it works but -3 didn't have anything explicitly targeted at this issue, just a bunch of corner case CVE fixes. So keep an eye out maybe it's still lingering
Comment 3 Jan ONDREJ 2017-07-26 11:02:40 EDT
(In reply to Cole Robinson from comment #2)
> Glad it works but -3 didn't have anything explicitly targeted at this issue,
> just a bunch of corner case CVE fixes. So keep an eye out maybe it's still
> lingering

Hmm, but still works. May be there was other update, which fixed this (selinux, dnsmasq, kernel, ...).

Trying to downgrade qemu and still works, I agree, that this didn't fixed this. If repeats, then I reopen it.
Comment 4 Jan ONDREJ 2017-08-10 02:06:58 EDT
Just for info, I found, what is the problem. My local named-chroot sometimes start and sometime don't after reboot, according to speed of network service startup. Looks like qemu can't use secondary DNS server from resolv.conf.
May be this can be a feature request to add usage of secondary nameservers.

Note You need to log in before you can comment on or make changes to this bug.