Bug 1473618 - Application pods getting deleted / going into error state after upgrade process
Application pods getting deleted / going into error state after upgrade process
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Scott Dodson
liujia
:
Depends On: 1472740
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-21 06:22 EDT by Tejas Chaphekar
Modified: 2017-07-24 10:35 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1472740
Environment:
Last Closed: 2017-07-24 10:35:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 liujia 2017-07-21 07:20:01 EDT
QE reproduced this issue,but it should be a normal issue, add more info:
Nginx* pods were created manually through "oc create -f xx.yaml" without dc or rc. So after "Drain Node", it should disappear. At the same time, those managed by dc/rc would be restored.

So it is expected.

But found another issue in above env, docker-registry and router can not be re-deployed, qe will try to reproduce this new find.
Comment 2 liujia 2017-07-24 01:02:06 EDT
Another issue about docker-registry and router can not be re-deployed which resulted that other app pods going error state. Checked above cluster, it should be a normal issue too. 

Because a pre-release docker registry need specified in /etc/sysconfig/docker, but not default one registry.access.redhat.com. So when upgrade 3.5 to 3.6 with quick installer, user should specify this option in the installer.cfg.yml.

case-quick installer 
openshift_docker_additional_registries: x.x.com 

So, according to QE's reproduce and test, it should not be a bug.
Comment 3 Scott Dodson 2017-07-24 10:35:41 EDT
Thanks, that seems correct.

Setting environment variables when running atomic-openshift-utils should enable those pre-release registries.

OO_INSTALL_INSECURE_REGISTRIES=registry.ops.openshift.com OO_INSTALL_ADDITIONAL_REGISTRIES=registry.ops.openshift.com

Note You need to log in before you can comment on or make changes to this bug.