Bug 1473640 - Restore with multiple ISOs does not detect additional ISOs due to blkid output parsing mismatch
Summary: Restore with multiple ISOs does not detect additional ISOs due to blkid outpu...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear
Version: 7.3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jakub Mazanek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1420851
TreeView+ depends on / blocked
 
Reported: 2017-07-21 11:15 UTC by Julio Entrena Perez
Modified: 2018-01-31 10:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-04 08:53:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1462189 None None None Never
Red Hat Knowledge Base (Solution) 3138501 None None None 2018-01-31 10:43:43 UTC

Internal Links: 1462189

Description Julio Entrena Perez 2017-07-21 11:15:23 UTC
Description of problem:
A backup that results in multiple ISO images due to ISO_MAX_SIZE= can not be restored.
After processing the first ISO, ReaR keeps prompting for the 2nd ISO image and is unable to recognise it.
Due to issue in bug 1462189 this means that there is no possible way of using the built-in backup method.

Version-Release number of selected component (if applicable):
rear-1.17.2-9.el7_3

How reproducible:
Always

Steps to Reproduce:
1. Configure the built-in backup method to limit the size of the output ISO images:

# cat /etc/rear/local.conf  | grep -v ^#
OUTPUT=ISO
OUTPUT_URL=file:///srv/backup
BACKUP=NETFS
BACKUP_URL=iso:///backup
ISO_MAX_SIZE=2048

2. Create rescue media with built-in backup ("rear mkbackup")

3. Boot with the first ISO image and wait for the prompt for the second ISO image.

4. Insert second ISO image.

Actual results:
ReaR keeps fails to detect and keeps prompting for additional ISO images.

Expected results:
ReaR detects additional ISO images and completes restore.

Additional info:
This is a known issue already fixed upstream: https://github.com/rear/rear/issues/1081

File /usr/share/rear/restore/NETFS/default/40_restore_backup.sh contains:

label=$(blkid /dev/${dev} | awk 'BEGIN{FS="[=\"]"} {print $3}')

But output of 'blkid' in the restore environment (once booted with the first ISO) is:

# blkid /dev/cdrom
/dev/cdrom: UUID="2017-07-19-11-10-00-00" LABEL="RELAXRECOVER_01" TYPE="iso9660"

So it's matching 2017-07-19-11-10-00-00 rather than RELAXRECOVER_01.

Full patch (combined with fix for issue https://github.com/rear/rear/pull/1082) is:

https://github.com/rear/rear/commit/938a2cf4302fca2b6fdff437669dd5c9fe36df53

The combination of this issue with genisoimage inability to create ISO images containing files larger than 4GB (see bug 1462189 ) results in the built-in backup method being completely broken, hence the severity.


Note You need to log in before you can comment on or make changes to this bug.