Bug 1473643 - When trying to add a duplicate class, no flash message is shown
When trying to add a duplicate class, no flash message is shown
Status: CLOSED DUPLICATE of bug 1428424
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Harpreet Kataria
Dave Johnson
automate:ui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 07:25 EDT by Milan Falešník
Modified: 2017-07-25 07:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 07:29:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core
mfalesni: automate_bug+


Attachments (Terms of Use)

  None (edit)
Description Milan Falešník 2017-07-21 07:25:49 EDT
Description of problem:
As subject says, when trying to add a duplicate class in a namespace, the flash message is not shown. However the duplicate class is not created, which makes it just a consmetic error.

Version-Release number of selected component (if applicable):
5.8.1.2

How reproducible:
always

Steps to Reproduce:
1. Create an automate namespace
2. Create a class (let's say "cls1")
3. Try creating a new class with the same name in the namespace

Actual results:
Class is not created, flash message not shown.

Expected results:
Class is not created, flash message is shown.

Additional info:
Comment 2 Greg McCullough 2017-07-21 09:03:33 EDT
Looks like we have the expected model validation in place: https://github.com/ManageIQ/manageiq/blob/master/app/models/miq_ae_class.rb#L14

Sending to UI team to review.
Comment 3 Milan Falešník 2017-07-25 07:29:20 EDT
Seems like it was unfixed for so long that even I forgot that I reported it 4 months ago :).

*** This bug has been marked as a duplicate of bug 1428424 ***

Note You need to log in before you can comment on or make changes to this bug.