This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1473656 - Review Request: perl-Unix-Process - Perl extension to get PID information from ps command
Review Request: perl-Unix-Process - Perl extension to get PID information fro...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1473663
  Show dependency treegraph
 
Reported: 2017-07-21 07:55 EDT by Petr Pisar
Modified: 2017-07-21 10:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Unix-Process-1.3101-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 10:40:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jplesnik: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2017-07-21 07:55:26 EDT
Spec URL: https://ppisar.fedorapeople.org/perl-Unix-Process/perl-Unix-Process.spec
SRPM URL: https://ppisar.fedorapeople.org/perl-Unix-Process/perl-Unix-Process-1.3101-1.fc27.src.rpm
Description:
This is a Perl module that can fetch ps command output fields.

Fedora Account System Username: ppisar
Comment 1 Jitka Plesnikova 2017-07-21 09:32:00 EDT
Source file is ok
Summary is ok
License is ok
Description is ok
URL and Source0 are ok
All tests passed
BuildRequires are ok

$ rpm -qp --requires perl-Unix-Process-1.3101-1.fc27.noarch.rpm | sort | uniq -c
      1 perl(:MODULE_COMPAT_5.26.0)
      1 perl(Carp)
      1 perl(IPC::System::Simple)
      1 perl(strict)
      1 perl(warnings)
      1 procps-ng
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
Binary requires are Ok.

$ rpm -qp --provides perl-Unix-Process-1.3101-1.fc27.noarch.rpm | sort | uniq -c
      1 perl(Unix::Process) = 1.3101
      1 perl-Unix-Process = 1.3101-1.fc27
Binary provides are Ok.

$ rpmlint ./perl-Unix-Process*
perl-Unix-Process.noarch: W: spelling-error Summary(en_US) ps -> PS, pa, pd
perl-Unix-Process.noarch: W: spelling-error %description -l en_US ps -> PS, pa, pd
perl-Unix-Process.src: W: spelling-error Summary(en_US) ps -> PS, pa, pd
perl-Unix-Process.src: W: spelling-error %description -l en_US ps -> PS, pa, pd
2 packages and 1 specfiles checked; 0 errors, 4 warnings.
Rpmlint is ok

The package looks good.
Approved
Comment 2 Gwyn Ciesla 2017-07-21 10:22:06 EDT
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/perl-Unix-Process
Comment 3 Petr Pisar 2017-07-21 10:40:01 EDT
Thank you for the review and the repository.

Note You need to log in before you can comment on or make changes to this bug.