Bug 1473661 - AltGr does not function in Container Terminal in some Windows browsers
AltGr does not function in Container Terminal in some Windows browsers
Status: CLOSED DUPLICATE of bug 1292507
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Samuel Padgett
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 08:00 EDT by Brendan Mchugh
Modified: 2017-07-21 08:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 08:28:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brendan Mchugh 2017-07-21 08:00:37 EDT
Description of problem:
Under Windows and using a Belgium azerty keyboard, AltGr does not function in Container Terminal in the Web Console.

Trying to enter the "|" symbol in terminal with "AltGr+1" fails, as do many other "AltGr+Character" combinations.


Version-Release number of selected component (if applicable):
openshift v3.5.5.26
kubernetes v1.5.2+43a9be4
etcd 3.1.0


How reproducible:
Always

Steps to Reproduce:
1. Switch keyboard in Windows to Belgian Azerty keymap
2. Try to enter "|" symbol in terminal with "AltGr+1"
3.

Actual results:
No character is sent to the terminal.

Expected results:
The character "|" should be sent to the terminal.

Additional info:
OS: Windows 10
Browsers tested all not sending AltGr+Character:
Internet Explorer 11
Edge
Chrome 59

However using Firefox 54, the character is sent to the terminal.
Comment 1 Jessica Forrester 2017-07-21 08:28:48 EDT

*** This bug has been marked as a duplicate of bug 1292507 ***

Note You need to log in before you can comment on or make changes to this bug.