Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1473722 - Rebase Systemtap for 7.5
Rebase Systemtap for 7.5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap (Show other bugs)
7.5
All Linux
unspecified Severity high
: rc
: 7.5
Assigned To: Frank Ch. Eigler
Martin Cermak
Vladimír Slávik
: Rebase
: 1520995 (view as bug list)
Depends On:
Blocks: 1393024 1425142 1471969 1522983 1485496
  Show dependency treegraph
 
Reported: 2017-07-21 09:47 EDT by mbenitez
Modified: 2018-04-10 12:33 EDT (History)
12 users (show)

See Also:
Fixed In Version: systemtap-3.2-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_systemtap_ rebased to version 3.2 The *SystemTap* utility has been updated to upstream version 3.2. Notable enhancements include: * Support for extraction of matched regular expression has been added. * Probe aliases for accepting input from the standard input have been added. * Translator diagnostics have been improved. * Support for the new `statx` system call has been added. * A new string function `strpos()` for detecting substring position has been added to the stap language. Additionally, this update fixes the following bugs: * Previously, the statistics extractor functions `@min()` and `@max()` returned incorrect values. As a consequence, scripts relying on these functions did not work properly. The `@min()` and `@max()` functions have been fixed to return the correct maximum and minimum values. As a result, the affected scripts now work as expected. * Previously, some kernel tracepoints were inconsistently listed with the `stap -L` command, even when they could not be probed. *SystemTap* has been fixed so that the listed and probe-able tracepoint sets match again. * The `netdev.receive` probe has been fixed and can collect data again. * The example script `nettop.stp` affected by the broken `netdev.receive` probe again works as expected. Note that the kernel version in Red Hat Enterprise Linux does not support extended Berkeley Packet Filter (eBPF), and consequently the related upstream *SystemTap* features are not available.
Story Points: ---
Clone Of:
: 1496221 (view as bug list)
Environment:
Last Closed: 2018-04-10 12:32:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0906 None None None 2018-04-10 12:33 EDT

  None (edit)
Description mbenitez 2017-07-21 09:47:31 EDT

    
Comment 17 John Jarvis 2018-01-10 09:20:23 EST
*** Bug 1520995 has been marked as a duplicate of this bug. ***
Comment 18 IBM Bug Proxy 2018-02-12 03:51:32 EST
------- Comment From shriykul@in.ibm.com 2018-02-12 03:42 EDT-------
Verified on Pegas 1.1 Snap 2:
===================

uname -r : 4.14.0-39.el7a.ppc64le
Machine : Boston + DD2.2

Testing :
======

[root@ltc-boston122 ~]# readelf -n /lib64/libc.so.6 | grep memory_mallopt_mmap_threshold -A2 -B2
stapsdt              0x00000051	NT_STAPSDT (SystemTap probe descriptors)
Provider: libc
Name: memory_mallopt_mmap_threshold
Location: 0x000000000009bbf0, Base: 0x00000000001a1010, Semaphore: 0x0000000000000000
Arguments: -4@30 8@0(9) -4@0(10)
[root@ltc-boston122 ~]# readelf -n /lib64/libc.so.6 | grep memory_mallopt_mmap_max -A2 -B2
stapsdt              0x0000004b	NT_STAPSDT (SystemTap probe descriptors)
Provider: libc
Name: memory_mallopt_mmap_max
Location: 0x000000000009bcc0, Base: 0x00000000001a1010, Semaphore: 0x0000000000000000
Arguments: -4@30 -4@0(7) -4@0(8)

Able to see the enteries in the format :

N@OP where
N maybe any one of -1, -2, -4, -8, 1, 2, 4, 8
OP maybe in any one of the following formats
iNUM or i-NUM
REG or %rREG
NUM(REG) or -NUM(REG) or NUM(%rREG) or -NUM(%rREG)
REG,REG or %rREG,%rREG
where NUM is any numeric constant and REG is a register
index (0 to 31).

[root@ltc-boston122 ~]# readelf -n /lib64/libc-2.17.so | grep "Arguments: "
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@28 -4@i1 -4@i0
Arguments: 8@27 -4@i1 -4@i0
Arguments: 8@23 -4@i1 -4@i0
Arguments: 8@23 -4@i1 -4@i0
Arguments: 8@23 -4@i1 -4@i0
Arguments: 8@23 -4@i1 -4@i0
Arguments: 8@29 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@25 -4@i1 -4@i0
Arguments: 8@25 -4@i1 -4@i0
Arguments: 8@25 -4@i1 -4@i0
Arguments: 8@27 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Arguments: 8@31 -4@i1 -4@i0
Comment 19 Martin Cermak 2018-02-16 09:11:05 EST
Finished testing systemtap-3.2-4.el7.
Comment 22 errata-xmlrpc 2018-04-10 12:32:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0906

Note You need to log in before you can comment on or make changes to this bug.