Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1473725 - Rebase Valgrind for 7.5
Rebase Valgrind for 7.5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: valgrind (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mark Wielaard
Miloš Prchlík
Vladimír Slávik
: Rebase
Depends On:
Blocks: 1471969
  Show dependency treegraph
 
Reported: 2017-07-21 09:50 EDT by mbenitez
Modified: 2018-04-10 09:14 EDT (History)
9 users (show)

See Also:
Fixed In Version: valgrind-3.13.0-9.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_valgrind_ rebased to version 3.13.0 The _valgrind_ package has been upgraded to version 3.13.0, which provides a number of bug fixes and enhancements over the previous version. Notable changes are: * *Valgrind* has been extended in several ways to run large programs. The amount of memory usable by *Valgrind* has been increased to 128 GB. As a consequence, the *Memcheck* tool supports running applications that allocate up to approximately 60 GB. Additionally, *Valgrind* can now load executable files up to 1200 MB in size. * The tools *Memcheck*, *Helgrind*, and *Massif* can now use a new execution tree (xtree) representation to report heap consumption of the analyzed applications. * The symbol demangler has been updated to support the C++11 standard and the Rust programming language. * Failures with long blocks of code using AVX2 instructions on the Intel and AMD 64-bit architecture have been fixed. * The 64-bit `timebase` register of the PowerPC architecture is no longer modeled by *Valgrind* as only 32-bit. * Support for the IBM Power Systems architecture has been extended to include the ISA 3.0B specification. * An alternative implementation of Load-Linked and Store-Conditional instructions for the 64-bit ARM architecture has been added. The alternative implementation is enabled automatically when required. To enable it manually, use the `--sim-hints=fallback-llsc` option.
Story Points: ---
Clone Of:
: 1496376 (view as bug list)
Environment:
Last Closed: 2018-04-10 09:14:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0773 None None None 2018-04-10 09:14 EDT

  None (edit)
Description mbenitez 2017-07-21 09:50:09 EDT

    
Comment 2 Mark Wielaard 2017-08-07 10:03:02 EDT
This would update valgrind from 3.12.x to 3.13.x.
3.13 was released upstream last June.
Comment 7 Miloš Prchlík 2018-01-05 08:55:05 EST
Verified for build valgrind-3.13.0-10.el7.
Comment 10 errata-xmlrpc 2018-04-10 09:14:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0773

Note You need to log in before you can comment on or make changes to this bug.