Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1473749 - libreoffice apps are unable to show license
libreoffice apps are unable to show license
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreoffice (Show other bugs)
7.5
x86_64 Linux
medium Severity low
: rc
: ---
Assigned To: David Tardon
Desktop QE
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 10:33 EDT by Martin Krajnak
Modified: 2018-04-10 08:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 08:03:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0751 None None None 2018-04-10 08:04 EDT

  None (edit)
Description Martin Krajnak 2017-07-21 10:33:15 EDT
Description of problem:
Clicking the license button in License Information dialog cause dialog to disappear but does not show the license information.

Version-Release number of selected component (if applicable):
libreoffice-impress-5.3.4.1-3.el7_2.x86_64


How reproducible:
always

Steps to Reproduce:
1.Open any libreoffice app (Impress in my case)
2.Navigate to "Help -> License Information..."
3.Click "Show License"

Actual results:
nothing is shown

Expected results:
Should show license information (I think that in previous version license file was displayed using LibreOffice Writer)

Additional info:
I am using the updated libreoffice version (libreoffice-impress-5.3.4.1-3.el7_2.x86_64) on RHEL 7.4
Comment 1 Caolan McNamara 2017-07-21 10:48:24 EDT
looks to me that the packaging moved the LICENSE.html file to /usr/share/doc/libreoffice-data so the attempt to find it in showDocument in sfx2/source/appl/appserv.cxx fails
Comment 2 David Tardon 2017-10-02 06:52:21 EDT
This has never appeared in any official RHEL version, just in the CSB one, so let's just close the bug silently...
Comment 3 Martin Krajnak 2017-11-16 03:50:51 EST
I can reproduce this bug with the most current version of LO:
libreoffice-5.3.6.1-4.el7.x86_64
Comment 6 Martin Krajnak 2017-12-20 08:27:55 EST
Fixed in version: 5.3.6.1-5.el7
Comment 10 errata-xmlrpc 2018-04-10 08:03:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0751

Note You need to log in before you can comment on or make changes to this bug.