Bug 1473760 - Using hawkular-tenant and curling the hawkular-metrics endpoint provides pods that aren't necessarily running
Using hawkular-tenant and curling the hawkular-metrics endpoint provides pods...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metrics (Show other bugs)
3.4.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matt Wringe
Junqi Zhao
: Unconfirmed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 10:46 EDT by Eric Jones
Modified: 2017-07-24 12:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 12:18:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2017-07-21 10:46:48 EDT
Description of problem:
Manually curling the metricsPublicURL and providing the Hawkular-Tenant header and specifying a namespace does not only specify the pods that are currently running.

Looking at the output in more detail it almost seems to show every version of that pod that has run.

Version-Release number of selected component (if applicable):
3.4.1

Providing more details soon in private update.
Comment 2 Matt Wringe 2017-07-24 12:18:56 EDT
We don't only store metrics for the currently running pods.

If you are running a replica set with 10 pods, you may want to know the usage for that replica set overtime. That requires knowing about all the pods which were running under that replica set and not just the current ones.

For data for the pods should automatically expire after a set time, and in more recent version the metrics definitions will automatically expire was well.

This is the intended behaviour.

Note You need to log in before you can comment on or make changes to this bug.