This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1473769 - [UPDATES] Tripleoclient exits abnormally from interactive mode
[UPDATES] Tripleoclient exits abnormally from interactive mode
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
high Severity high
: z2
: 11.0 (Ocata)
Assigned To: Rabi Mishra
Ronnie Rasouli
: Triaged, ZStream
Depends On:
Blocks: 1487162
  Show dependency treegraph
 
Reported: 2017-07-21 11:02 EDT by Yurii Prokulevych
Modified: 2017-09-13 17:40 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-heat-8.0.3-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1487162 (view as bug list)
Environment:
Last Closed: 2017-09-13 17:40:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1653990 None None None 2017-07-25 05:02 EDT
OpenStack gerrit 480627 None None None 2017-07-25 05:02 EDT

  None (edit)
Description Yurii Prokulevych 2017-07-21 11:02:55 EDT
Description of problem:
-----------------------
During minor update client might exit abnormally. E.g:
openstack overcloud update stack -i overcloud                                                                                                                    
Started Mistral Workflow tripleo.package_update.v1.package_update_plan. Execution ID: 8b669b90-63ac-43af-a9d1-8956084d0593
Waiting for messages on queue 'ace039d4-cf5b-4d7c-b8cc-37ab5d9f8269' with no timeout.
IN_PROGRESS
WAITING
on_breakpoint: [u'ceph-1', u'ceph-2', u'ceph-0', u'compute-1', u'controller-2', u'controller-1', u'controller-0', u'compute-0']
Breakpoint reached, continue? Regexp or Enter=proceed (will clear 21ae45fe-e4b1-4df1-ac0b-e7c413018d0e), no=cancel update, C-c=quit interactive mode: 
IN_PROGRESS
WAITING
completed: [u'compute-0']
...
WAITING
completed: [u'ceph-1', u'ceph-2', u'ceph-0', u'compute-1', u'controller-2', u'controller-1', u'compute-0']
on_breakpoint: [u'controller-0']
Breakpoint reached, continue? Regexp or Enter=proceed (will clear c2273c1e-b6f3-4c11-8ce5-7d0f420c7e15), no=cancel update, C-c=quit interactive mode: 
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
ERROR: u'u\'ControllerPostPuppet\'\n

The run eventually succeeds:
openstack stack list
+--------------------------------------+------------+--------------------+----------------------+----------------------+
| ID                                   | Stack Name | Stack Status       | Creation Time        | Updated Time         |
+--------------------------------------+------------+--------------------+----------------------+----------------------+
| b78294cf-3d20-4edb-98b3-f0878b53fc00 | overcloud  | UPDATE_IN_PROGRESS | 2017-07-21T08:31:23Z | 2017-07-21T11:59:43Z |
+--------------------------------------+------------+--------------------+----------------------+----------------------+

openstack stack list
+--------------------------------------+------------+-----------------+----------------------+----------------------+
| ID                                   | Stack Name | Stack Status    | Creation Time        | Updated Time         |
+--------------------------------------+------------+-----------------+----------------------+----------------------+
| b78294cf-3d20-4edb-98b3-f0878b53fc00 | overcloud  | UPDATE_COMPLETE | 2017-07-21T08:31:23Z | 2017-07-21T11:59:43Z |
+--------------------------------------+------------+-----------------+----------------------+----------------------+


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-tripleo-puppet-elements-6.1.0-1.el7ost.noarch
openstack-tripleo-common-6.1.0-2.el7ost.noarch
puppet-tripleo-6.5.0-5.el7ost.noarch
python-tripleoclient-6.2.0-1.el7ost.noarch
openstack-tripleo-image-elements-6.1.0-1.el7ost.noarch
openstack-tripleo-validations-5.5.0-2.el7ost.noarch
openstack-tripleo-ui-3.2.0-1.el7ost.noarch
openstack-tripleo-heat-templates-6.1.0-2.el7ost.noarch



How reproducible:
-----------------
Unfortunately not 100%

Steps to Reproduce:
-------------------
1. Run minor update of oc
Comment 6 Ronnie Rasouli 2017-09-07 06:48:06 EDT
verified
update from 7.4-testing to latest RHOS11 latest Z stream running 
openstack overcloud update stack -i overcloud finished successfully
Comment 8 errata-xmlrpc 2017-09-13 17:40:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2720

Note You need to log in before you can comment on or make changes to this bug.