Bug 1473774 - (CVE-2017-11450) CVE-2017-11450 ImageMagick: Too short JPEG data causes denial of service in coders/jpeg.c
CVE-2017-11450 ImageMagick: Too short JPEG data causes denial of service in c...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
impact=low,public=20170721,reported=2...
: Security
Depends On: 1473775
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 11:26 EDT by Pedro Sampaio
Modified: 2018-06-29 18:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Sampaio 2017-07-21 11:26:38 EDT
coders/jpeg.c in ImageMagick before 7.0.6-1 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via JPEG data that is too short.

Upstream patch:

https://github.com/ImageMagick/ImageMagick/commit/948356eec65aea91995d4b7cc487d197d2c5f602

References:

https://github.com/ImageMagick/ImageMagick/issues/556
Comment 1 Pedro Sampaio 2017-07-21 11:26:52 EDT
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1473775]

Note You need to log in before you can comment on or make changes to this bug.