Bug 1473782 - Automate Domain Switches if user Switches Groups after a Request
Automate Domain Switches if user Switches Groups after a Request
Status: CLOSED DUPLICATE of bug 1467364
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.7.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: Lucy Fu
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 12:10 EDT by myoder
Modified: 2017-12-05 10:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 14:27:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description myoder 2017-07-21 12:10:56 EDT
Description of problem:
We have users belonging to several groups and have one automation domain per tenant.  These automation domains contain some variables (remote system hostname, user / password) to access third party API (exemple LDAP server).

If a user submits a provision request, when a user switches his current group, the automation domain of the request is also switched and so we are forced to ask them to not switch their current group during the processing of a request.

Version-Release number of selected component (if applicable):
CFME 5.7 (will update with the full buid soon)

How reproducible:
customer environment

Steps to Reproduce:
1. Have a user submit a provision request
2. Have user switch groups before the provision request is finished
3.

Actual results:
The automate domain of the request is switched to correlate to the "current" group the user belongs to.

Expected results:
The automate domain should remain the same automate domain as when the provision request was initially requested.

Additional info:
Comment 3 Lucy Fu 2017-07-27 14:27:16 EDT

*** This bug has been marked as a duplicate of bug 1467364 ***

Note You need to log in before you can comment on or make changes to this bug.