Bug 1473783 - Group is ignored in API request when Provisioning
Group is ignored in API request when Provisioning
Status: CLOSED DUPLICATE of bug 1467364
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.7.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: Greg McCullough
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 12:11 EDT by myoder
Modified: 2017-12-05 10:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 13:07:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description myoder 2017-07-21 12:11:09 EDT
Description of problem:
When a user submits an API request, the group used for the request is the last group the user was logged into in the Web UI, and not the group that is submitted in the API request.

Version-Release number of selected component (if applicable):
CFME 5.7 (will update with the full build soon)

How reproducible:
Customer enviornment

Steps to Reproduce:
1. Have a user switch to "Group B" in the Web UI
2. Have user send an API provision request with the desired group "Group A" in the request

Actual results:
The group used for the provision is "Group B"

Expected results:
The group used for the provision should be "Group A"

Additional info:
Comment 4 Lucy Fu 2017-08-01 13:07:13 EDT

*** This bug has been marked as a duplicate of bug 1467364 ***

Note You need to log in before you can comment on or make changes to this bug.