Bug 147383 - wrong "file not found by glob" error
wrong "file not found by glob" error
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 14:54 EST by Alexander Suvorov
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:07:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file for testing bug (321 bytes, text/plain)
2005-02-07 14:57 EST, Alexander Suvorov
no flags Details
patch that fixes the bug (364 bytes, patch)
2005-02-07 14:58 EST, Alexander Suvorov
no flags Details | Diff

  None (edit)
Description Alexander Suvorov 2005-02-07 14:54:12 EST
Description of problem: 
we can't use files with special wildcard symbols as regular files in 
%files section of spec-file. I.e. file "test-*.txt" 
when we try to add to rpm such file we get message: 
 
error: File not found by glob: <filename> 
 
 
Version-Release number of selected component (if applicable): 
rpm-4.2.3-13 
 
How reproducible: 
Every time 
 
Steps to Reproduce: 
1. get attached test.spec file 
2. run rpmbuild -bb test.spec 
3. we've got an error 
   
Actual results: 
we've got an error: 
error: File not found by glob: <filename> 
 
Expected results: 
the rpm must be built succesfully 
 
Additional info: 
I include a simple patch that fixes this bug, but I don't sure that 
this extra check of myGlobPatternP(argv[0]) is completely 
unnecessary. 
 
So, if this check is needed for rpm correct working, please, find 
another way to fix error in processing files with wildcard-symbols 
in it's name. 
 
Patch must be appled to the file build/files.c
Comment 1 Alexander Suvorov 2005-02-07 14:57:47 EST
Created attachment 110745 [details]
spec file for testing bug
Comment 2 Alexander Suvorov 2005-02-07 14:58:48 EST
Created attachment 110746 [details]
patch that fixes the bug
Comment 3 Tim Nelson 2005-04-06 03:11:51 EDT
Is this at all related to bug #139460 ?  Because I'm experiencing the problem
mentioned in that bug, but on Redhat Enterprise instead of Fedora.  
Comment 4 Jeff Johnson 2007-01-03 12:18:57 EST
Fixed in rpm cvs, will be in rpm-4.4.8-0.9 when built.

UPSTREAM
Comment 5 RHEL Product and Program Management 2007-10-19 15:07:37 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.