Bug 1473832 - CF unable to refresh after the restore of the overcloud database
CF unable to refresh after the restore of the overcloud database
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.7.0
All All
unspecified Severity urgent
: GA
: 5.6.5
Assigned To: Tzu-Mainn Chen
Ola Pavlenko
openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 15:59 EDT by Josh Carter
Modified: 2017-08-07 08:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:36:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Openstack


Attachments (Terms of Use)

  None (edit)
Description Josh Carter 2017-07-21 15:59:54 EDT
Description of problem:

CF unable to refresh after the restore of the overcloud database

Overcloud database had to be restored to an earlier date along with a change of ips for the overcloud. 

Debug fog output shows that cloudforms is receiving 500 errors from openstack when requesting data from the stack api's  

Version-Release number of selected component (if applicable): 5.7.*


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 6 Felix Dewaleyne 2017-07-21 18:52:26 EDT
all attempts to pull data meet an invailid token error.

the token cloudforms tries to use to use /ressources is always the same.
Comment 7 Felix Dewaleyne 2017-07-21 20:28:40 EDT
this is 5.6.3.3 - the error turns out to be a part of an openstack error which can be reproduced when you try to access the ressource info for the stack
Comment 8 Felix Dewaleyne 2017-07-21 21:45:00 EDT
issue resolved but the way messages from the openstack 9 environment were passed were seriously misleading. 

the problem was that the tokens couldn't be decrypted from the openstack database making it output "invalid token". we had no way to know if that is the token passed for the api request or something else.

Note You need to log in before you can comment on or make changes to this bug.