Bug 147386 - stopping iptables hangs at 'modprob -r ip_tables'
stopping iptables hangs at 'modprob -r ip_tables'
Status: CLOSED DUPLICATE of bug 112630
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 15:32 EST by Brian Millett
Modified: 2015-01-04 17:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 07:34:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Millett 2005-02-07 15:32:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
I am running rawhide, kernel 2.6.10-1.1126_FC4 and also 
NetworkManager-0.3.3-1.cvs20050202.3.1.  

When NetworkManager has made a connection, then when I try to stop
iptables (process 1), it hangs on "modprobe -r ip_tables".  If I stop
NetworkManager (process 2), then the "process 1" continues and stops.
 I can start and stop iptables as long as NetworkManager is stopped,
or has not yet made an active connection.  When I start NetworkManager
and make an active connection, I also can not start iptables.

Only message I get when I try to modprob -r ip_tables by hand when
NetworkManaager is working and active:

FATAL: Module ip_tables is in use. 

The behavior that is expected (start/stop iptables with active
NetworkManager connection) works for kernel 2.6.10-1.1115_FC4

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have NetworkManager started and have an avtive connection
2. execute service iptables stop
3. wait forever
    

Actual Results:  system is hung waiting to terminate iptables.

Expected Results:  iptables should be terminated.

Additional info:

I can not really tell if this is a NetworkManager bug, but since it
works with other kernel revs, I think it is kernel related.
Comment 1 Jay Turner 2005-03-01 07:34:00 EST

*** This bug has been marked as a duplicate of 112630 ***

Note You need to log in before you can comment on or make changes to this bug.