Bug 1473863 - live-migration with boot from volume + config_drive takes a very long time.
live-migration with boot from volume + config_drive takes a very long time.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
10.0 (Newton)
x86_64 Linux
high Severity urgent
: z2
: 12.0 (Pike)
Assigned To: Matthew Booth
awaugama
: Reopened, Triaged, ZStream
Depends On:
Blocks: 1537068 1537069
  Show dependency treegraph
 
Reported: 2017-07-21 18:01 EDT by Siggy Sigwald
Modified: 2018-03-28 13:20 EDT (History)
23 users (show)

See Also:
Fixed In Version: openstack-nova-16.0.2-10.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1537068 1537069 (view as bug list)
Environment:
Last Closed: 2018-03-28 13:19:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1719362 None None None 2017-09-25 12:42 EDT
OpenStack gerrit 507202 None master: MERGED nova: libvirt: Don't VIR_MIGRATE_NON_SHARED_INC without migrate_disks (I9b545ca8aa6dd7b41ddea2d333190c9fbed19bc1) 2018-01-22 07:27 EST
OpenStack gerrit 519631 None stable/pike: MERGED nova: libvirt: bandwidth param should be set in guest migrate (I8a37753dea8eca7b26466f17dfbdc184c48c24c5) 2018-01-22 07:27 EST
OpenStack gerrit 519632 None stable/pike: MERGED nova: libvirt: Don't VIR_MIGRATE_NON_SHARED_INC without migrate_disks (I9b545ca8aa6dd7b41ddea2d333190c9fbed19bc1) 2018-01-22 07:27 EST
Red Hat Product Errata RHBA-2018:0605 None None None 2018-03-28 13:20 EDT

  None (edit)
Comment 1 Andreas Karis 2017-07-24 12:15:40 EDT
Hello,

Can we get some traction for this BZ?

Thanks,

Andreas
Comment 4 Matthew Booth 2017-07-28 12:57:37 EDT
I can't reproduce this locally, btw. Migration of boot from volume with config drive completes normally here.
Comment 9 awaugama 2017-09-07 15:11:47 EDT
Closed without a fix therefore QE won't automate
Comment 26 Matthew Booth 2017-09-25 10:47:03 EDT
I've now reproduced this locally.
Comment 33 Matthew Booth 2018-01-31 09:38:04 EST
Reproducer:

1. Create a boot-from-volume instance with a large root disk (e.g. 100G) and a config disk, but no other disks.
2. Live migrate the instance.

The bug can be considered verified if the live migration completes faster than the root disk could reasonably have been copied over the network. That is, a lightly loaded instance should live migrate in 'a few' seconds.

The bug can be directly verified by enabling libvirt debug logging and observing that no block migration of the root disk takes place, or by noting that migrateToURI3() is called with no/empty migrate_disks parameter and without VIR_MIGRATE_NON_SHARED_INC (value 128) in flags.
Comment 41 errata-xmlrpc 2018-03-28 13:19:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0605

Note You need to log in before you can comment on or make changes to this bug.