Bug 1473865 - spacewalk-remote-utils-2.5.1-6 is missing RHEL 7.3 channel definitions
spacewalk-remote-utils-2.5.1-6 is missing RHEL 7.3 channel definitions
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
570
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michael Mráka
Martin Korbel
:
Depends On:
Blocks: sat58-errata
  Show dependency treegraph
 
Reported: 2017-07-21 18:19 EDT by Candace Sheremeta
Modified: 2017-08-15 09:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 09:27:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Candace Sheremeta 2017-07-21 18:19:05 EDT
the channel definitions for RHEL 7.3 have disappeared from spacewalk-remote-utils-2.5.1-6. Please advise. Thank you!

[root@nwd3rhnsat1 ~]# rpm -qa spacewalk-remote-utils
spacewalk-remote-utils-2.5.1-6.el5sat

If I search for 7u3 channel data, it returns nothing:
[root@nwd3rhnsat1 ~]# rpm -ql spacewalk-remote-utils | grep 7-u3

Where if I search for 7-u2, I get:
[root@nwd3rhnsat1 ~]# rpm -ql spacewalk-remote-utils | grep 7-u2
/usr/share/rhn/channel-data/7-u2-client-x86_64
/usr/share/rhn/channel-data/7-u2-client-x86_64-Optional
/usr/share/rhn/channel-data/7-u2-client-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u2-computenode-x86_64
/usr/share/rhn/channel-data/7-u2-computenode-x86_64-Optional
/usr/share/rhn/channel-data/7-u2-computenode-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u2-server-ppc64
/usr/share/rhn/channel-data/7-u2-server-ppc64-Optional
/usr/share/rhn/channel-data/7-u2-server-ppc64-Supplementary
/usr/share/rhn/channel-data/7-u2-server-s390x
/usr/share/rhn/channel-data/7-u2-server-s390x-Highavailability
/usr/share/rhn/channel-data/7-u2-server-s390x-Optional
/usr/share/rhn/channel-data/7-u2-server-s390x-Resilientstorage
/usr/share/rhn/channel-data/7-u2-server-s390x-Supplementary
/usr/share/rhn/channel-data/7-u2-server-x86_64
/usr/share/rhn/channel-data/7-u2-server-x86_64-Highavailability
/usr/share/rhn/channel-data/7-u2-server-x86_64-Optional
/usr/share/rhn/channel-data/7-u2-server-x86_64-Resilientstorage
/usr/share/rhn/channel-data/7-u2-server-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u2-workstation-x86_64
/usr/share/rhn/channel-data/7-u2-workstation-x86_64-Optional
/usr/share/rhn/channel-data/7-u2-workstation-x86_64-Supplementary
Comment 1 Michael Mráka 2017-07-24 09:13:04 EDT
Spacewalk upstream commits
commit 8af97691a183f0da1def4f885d93c9da203ca454
    Updating spacewalk-create-channel to gather Supplementary channels
commit 37ef8da39bb8fe7d7f019f7f2405ff4c1a78bea1
    update of spacewalk-remote-utils with RHEL 7.3 channel definitions
Comment 3 Michael Mráka 2017-08-03 04:42:56 EDT
Backported to SATELLITE-5.8 
commit da8d57ba9a52892009ede6fe7603023b3bd090e0
    1473865 - Updating spacewalk-create-channel to gather Supplementary channels
Comment 4 Michael Mráka 2017-08-03 04:46:18 EDT
Backported to SATELLITE-5.8 
commit 2ee51d532d7b31c9f2c634b6dfbcb29b431df178
    1473865 - Supplementary channels for RHEL 7.3 channel definitions
commit e7d769e986f2006d28a49a6d25f0aa05a4ac588a
    1473865 - update of spacewalk-remote-utils with RHEL 7.3 channel definitions
Comment 5 Martin Korbel 2017-08-09 04:23:09 EDT
VERIFIED on spacewalk-remote-utils-2.5.1-9

> rpm -ql spacewalk-remote-utils | grep 7-u3
/usr/share/rhn/channel-data/7-u3-client-x86_64
/usr/share/rhn/channel-data/7-u3-client-x86_64-Optional
/usr/share/rhn/channel-data/7-u3-client-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u3-computenode-x86_64
/usr/share/rhn/channel-data/7-u3-computenode-x86_64-Optional
/usr/share/rhn/channel-data/7-u3-computenode-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u3-server-ppc64
/usr/share/rhn/channel-data/7-u3-server-ppc64-Optional
/usr/share/rhn/channel-data/7-u3-server-ppc64-Supplementary
/usr/share/rhn/channel-data/7-u3-server-s390x
/usr/share/rhn/channel-data/7-u3-server-s390x-Highavailability
/usr/share/rhn/channel-data/7-u3-server-s390x-Optional
/usr/share/rhn/channel-data/7-u3-server-s390x-Resilientstorage
/usr/share/rhn/channel-data/7-u3-server-s390x-Supplementary
/usr/share/rhn/channel-data/7-u3-server-x86_64
/usr/share/rhn/channel-data/7-u3-server-x86_64-Highavailability
/usr/share/rhn/channel-data/7-u3-server-x86_64-Optional
/usr/share/rhn/channel-data/7-u3-server-x86_64-Resilientstorage
/usr/share/rhn/channel-data/7-u3-server-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u3-workstation-x86_64
/usr/share/rhn/channel-data/7-u3-workstation-x86_64-Optional
/usr/share/rhn/channel-data/7-u3-workstation-x86_64-Supplementary
Comment 7 errata-xmlrpc 2017-08-15 09:27:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2474

Note You need to log in before you can comment on or make changes to this bug.