Bug 1473885 - Uncaught errors cause login page redirect with no indication of error in browser or server logs
Uncaught errors cause login page redirect with no indication of error in brow...
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.3.8
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Burman
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-21 22:45 EDT by Josh West
Modified: 2017-08-10 10:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-27 10:26:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh West 2017-07-21 22:45:38 EDT
Description of problem:

The JON login page has issues with error handling. When installing the JON server with incorrect settings or running on a VM that is short on the necessary memory you are unable to log into the JON Server.  Without any errors showing up in the logs, or in the UI a successful login simply redirects back to the login page.  

Version-Release number of selected component (if applicable):


How reproducible:

Somewhat intermittent. Suggest putting JON on a host with 1G or less of memory to reproduce. 

Steps to Reproduce:
1. Install and start server without the minimum memory - 1GB or less
2. Attempt to login with correct credentials - eg: rhqamdin/rhqadmin

Actual results:

Return to the login page with no error noted in the browser, nor in the server logs. 

Expected results:

If the server is having issues, the expectation is a browser side error to be reported, or an error in the log file.
Comment 1 Michael Burman 2017-07-24 12:32:01 EDT
If the server has had OutOfMemory event, then there's no guarantee that any error handling is possible. That's because at the OutOfMemory, JVM might have removed the actual error handling from the memory.
Comment 2 Filip Brychta 2017-07-27 10:26:15 EDT
Triage: Larry, Simeon, Filip - based on comment 1 and the fact that recommended memory for JON server is 4 GB and JON is in maintenance period closing as won't fix.

Note You need to log in before you can comment on or make changes to this bug.