Bug 1473897 - borgbackup 1.0.11 is available
borgbackup 1.0.11 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: borgbackup (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Benjamin Pereto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-22 03:02 EDT by Felix Schwarz
Modified: 2017-08-20 15:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: borgbackup-1.0.11-3.fc26 borgbackup-1.0.11-3.fc25 borgbackup-1.0.11-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 11:57:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2017-07-22 03:02:49 EDT
borg 1.0.11 is available: https://github.com/borgbackup/borg/releases/tag/1.0.11

Changelog: https://github.com/borgbackup/borg/blob/1.0.11/docs/changes.rst#version-1011-2017-07-21

This release includes bug fixes and minor new features but also one fix marked as "security precaution".

It would be nice to get this version into Fedora+EPEL especially because it contains some performance improvements ("rebuild hashtable if we have too few empty buckets") and future-proofing in case borg accesses a repo created with a newer borg version ("add minimal version of in repository mandatory feature flags").
Comment 1 Fedora Update System 2017-07-29 11:43:15 EDT
borgbackup-1.0.11-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a04eaff1fb
Comment 2 Fedora Update System 2017-07-29 11:44:17 EDT
borgbackup-1.0.11-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-040385e13a
Comment 3 Benjamin Pereto 2017-07-29 11:46:19 EDT
epel7 build stucks for ppc64:

DEBUG util.py:439:  Getting requirements for borgbackup-1.0.11-1.el7.src
DEBUG util.py:439:   --> python34-devel-3.4.5-2.el7.ppc64
DEBUG util.py:439:   --> python34-setuptools-19.2-3.el7.noarch
DEBUG util.py:439:   --> python34-setuptools_scm-1.10.1-2.el7.noarch
DEBUG util.py:439:   --> python34-Cython-0.23.5-1.el7.ppc64
DEBUG util.py:439:   --> python34-llfuse-1.0-1.el7.ppc64
DEBUG util.py:439:   --> python34-pytest-2.8.5-2.el7.noarch
DEBUG util.py:439:   --> python34-msgpack-0.4.8-1.el7.ppc64
DEBUG util.py:439:   --> python-sphinx-1.1.3-11.el7.noarch
DEBUG util.py:439:   --> python-sphinx_rtd_theme-0.1.8-4.el7.noarch
DEBUG util.py:439:   --> fuse-2.9.2-7.el7.ppc64
DEBUG util.py:439:   --> 1:openssl-devel-1.0.1e-60.el7_3.1.ppc64
DEBUG util.py:439:   --> lz4-devel-1.7.3-1.el7.ppc64
DEBUG util.py:439:   --> fuse-devel-2.9.2-7.el7.ppc64
DEBUG util.py:439:   --> libacl-devel-2.2.51-12.el7.ppc64
DEBUG util.py:439:  Error: Package: python-sphinx_rtd_theme-0.1.8-4.el7.noarch (build)
DEBUG util.py:439:             Requires: font(fontawesome)
DEBUG util.py:439:  Error: Package: python-sphinx_rtd_theme-0.1.8-4.el7.noarch (build)
DEBUG util.py:439:             Requires: fontawesome-fonts-web
DEBUG util.py:439:   You could try using --skip-broken to work around the problem
DEBUG util.py:439:   You could try running: rpm -Va --nofiles --nodigest
DEBUG util.py:577:  Child return code was: 1


Needs to work before it can be tagged.
Comment 4 Fedora Update System 2017-07-30 05:33:44 EDT
borgbackup-1.0.11-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e5a566735f
Comment 5 Benjamin Pereto 2017-07-30 05:34:44 EDT
removed sphinx_rtd_theme dependency.
this is only needed to build the html version for readthedocs.com, not for manpages.
Comment 6 Fedora Update System 2017-07-30 05:35:41 EDT
borgbackup-1.0.11-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9a1efd3fd3
Comment 7 Fedora Update System 2017-07-30 05:36:15 EDT
borgbackup-1.0.11-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8abdc08479
Comment 8 Fedora Update System 2017-07-30 20:48:27 EDT
borgbackup-1.0.11-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-e5a566735f
Comment 9 Fedora Update System 2017-07-30 22:22:17 EDT
borgbackup-1.0.11-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8abdc08479
Comment 10 Fedora Update System 2017-07-31 00:24:02 EDT
borgbackup-1.0.11-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9a1efd3fd3
Comment 11 Fedora Update System 2017-08-09 11:57:54 EDT
borgbackup-1.0.11-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2017-08-09 15:58:21 EDT
borgbackup-1.0.11-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2017-08-20 15:21:34 EDT
borgbackup-1.0.11-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.