Bug 147391 - Kernel cannot initialize kernel journaling features
Kernel cannot initialize kernel journaling features
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 15:44 EST by Tate Austin
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 05:18:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tate Austin 2005-02-07 15:44:57 EST
Description of problem:
I left my computer for several days, it was running bittorrent (all
legal-content torrents) and when I returned
Azureus(http://azureus.sourceforge.net/) reported write errors
regarding the downloads.  This was merely the beginning, kuickshow
dropped errors when I tried to view directories with it, as did file
browser itself, showing me no files.  I eventually acted on the belief
this was x-related pressed ctrl+alt+backspace, instead of
reinitializing X-windows, I was treated to a screen full of errors
regarding the journaling: "error loading journal."  So I took the next
step which was to reboot.  Upon reboot I was given this error:

JBD: Failed to Read Block offset 6540
Ext3-fs:error loading journal.

I suspect this to be a resurgence of this bug:
https://listman.redhat.com/archives/ext3-users/2001-March/msg00018.html

Kernel problem interracting with ext-3.  It would seem that while this
was at one time fixed, there is a selective condition for it to
reappear?  I will attempt to run 'tune2fs' this evening and see if
that is actually a solution and update this entry if I get any
meaningful feedback.
Version-Release number of selected component (if applicable):
ext-3

How reproducible:
current load of OS unloadable

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tate Austin 2005-02-07 16:09:25 EST
Oh I think a salient detail is that my harddrive is a serial ATA
drive, so perhaps this is some kind of write issue with the driver.
Comment 2 Tate Austin 2005-02-07 20:02:19 EST
Okay more salient data, I tried a rescue console boot, and if I
attempt to scan for a FC3 installation, it locks up.  If I skip that
step, there is no /dev/hdc for me to tune2fs -j....   But, I used
knoppix, this one did indeed mount the drive.  But in attempting to
run "tune2fs -j /mnt/hdg3" it tells me there is "No Valid Superblock"
and does nothing.
Comment 3 Stephen Tweedie 2005-02-15 07:35:13 EST
The error

JBD: Failed to Read Block offset 6540
Ext3-fs:error loading journal.

indicates that there was a disk IO error when ext3 was trying to recover the
journal.  There's nothing that the kernel can do to proceed in that case.  As to
why the device isn't seen, I've no idea.
Comment 4 Tate Austin 2005-02-15 08:47:23 EST
Sorry guys, case closed.  The drive just died when I tried to reinstall.  I
don't know why windows was working perfectly off it, but then I attempted to
reload the drive was apparently badly damaged as to not let windows or linux
reinstall on it.  I think this was just some damaged area of the drive that went
unnoticed when it was confined to just the linux partition, but once I tried to
repartition; everything went overboard.  So I think this was just a hardware
issue and that is that.

Note You need to log in before you can comment on or make changes to this bug.