Bug 1473942 - 2.6-8 breaks WLAN [NEEDINFO]
2.6-8 breaks WLAN
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
26
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-22 11:40 EDT by t.soernes
Modified: 2017-08-07 07:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 07:24:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bgalvani: needinfo? (t.soernes)


Attachments (Terms of Use)
dnf history (11.44 KB, text/plain)
2017-07-22 11:40 EDT, t.soernes
no flags Details
networkmanager log (1.23 MB, text/plain)
2017-07-22 11:42 EDT, t.soernes
no flags Details

  None (edit)
Description t.soernes 2017-07-22 11:40:48 EDT
Created attachment 1302803 [details]
dnf history

Description of problem:
After updating to 2.6-8 yesterday WiFi conked out. AP would be visible in NetworkManager for a second, but connecting not possible, afterwards no APs detected at all. Downgrading to 2.6-7 and Wifi works again. 

Additional info:
Fedora 26 KDE, wlan driver ar9170, wlan card TP-Link TL-WN821N v2.
Comment 1 t.soernes 2017-07-22 11:42 EDT
Created attachment 1302804 [details]
networkmanager log

Network manager log. You can see things acting up after update.
Comment 2 Beniamino Galvani 2017-07-24 04:50:38 EDT
wpa_supplicant 2.6-8 has only two additional patches compared to 2.6-7 and they should only affect WPA-Enterprise connections:

 - OpenSSL: use system ciphers by default (rh #1462262)
 - OpenSSL: fix private key password callback (rh #1465138)

Since also NetworkManager was upgraded, maybe it's the cause of the problem?
Can you please try the following combinations and check which ones work?

 1) NetworkManager-1:1.8.0-6
    wpa_supplicant-1:2.6-8

 2) NetworkManager-1:1.8.2-1
    wpa_supplicant-1:2.6-7

Also, can you please attach trace logs for the failure, captured with:

  # add '-dd' to OTHER_ARGS in /etc/sysconfig/wpa_supplicant
  systemctl restart wpa_supplicant
  nmcli general logging level TRACE
  nmcli connection up <wifi-connection>
  journalctl -u NetworkManager -u wpa_supplicant --since "2 minutes ago"

Thanks!
Comment 3 t.soernes 2017-08-07 07:24:59 EDT
Bought a new WLAN adapter instead. All good now

Note You need to log in before you can comment on or make changes to this bug.