Bug 1473972 - sporadic disk "lockup" occurring when moving away from remmina window
sporadic disk "lockup" occurring when moving away from remmina window
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: remmina (Show other bugs)
26
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-22 17:31 EDT by Jason Haar
Modified: 2018-01-13 18:05 EST (History)
2 users (show)

See Also:
Fixed In Version: remmina-1.2.0-0.39.20170724git0387ee0.fc26 remmina-1.2.0-0.39.20170724git0387ee0.fc25 remmina-1.2.0-0.44.rcgit.26.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 12:21:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Haar 2017-07-22 17:31:54 EDT
Description of problem:

A few times a day I'll go to change workspace away from my remmina sessions by "swooping out" and instead of that happening, my Dell laptop disk light will go solid and the system locks up for 4-6sec before going OK again. This will not repeat itself immediately - the system will then act normally for hours before doing it again.

The only logs that appear related are a small number of these

Jul 23 09:02:54 mylaptop org.gnome.Shell.desktop: Window manager warning: 0x424bcc4 (remmina) appears to be one of the offending windows with a timestamp of 654685821.  Working around...
Jul 23 09:02:54 mylaptop org.gnome.Shell.desktop: Window manager warning: last_user_time (654685941) is greater than comparison timestamp (654685936).  This most likely represents a buggy client sending inaccurate timestamps in messages such as _NET_ACTIVE_WINDOW.  Trying to work around...

I use remmina to manage SSH and RDP sessions if that matters



Version-Release number of selected component (if applicable):


How reproducible:

sporadic

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

I have tonnes of RAM - this isn't swapping related. The syslogs don't show evidence of any other kind of activity that could be I/O related, but there is always WIFI related logging going on when these occur (as before, not at a level to cause the light to go solid), so maybe it's some kind of feedback between networking and remmina?? Does remmina get/rely on network information via dbus/systemd/whatever? I use remmina to manage ssh and RDP sessions to systems that are continents away, and so I know for a fact remmina doesn't mind "high latency" network issues (ie which are OS level), but maybe it listens too much to chatter via the user-space network APIs? Just thinking out loud - no idea if that is true - just trying to help :-)
Comment 1 Fedora Update System 2017-07-27 09:33:57 EDT
remmina-1.2.0-0.39.20170724git0387ee0.fc26 freerdp-2.0.0-31.20170724gitf8c9f43.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4bc09c2364
Comment 2 Fedora Update System 2017-07-27 09:34:25 EDT
remmina-1.2.0-0.39.20170724git0387ee0.fc25 freerdp-2.0.0-31.20170724gitf8c9f43.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ed31e1f941
Comment 3 Fedora Update System 2017-07-28 18:19:19 EDT
freerdp-2.0.0-31.20170724gitf8c9f43.fc25, remmina-1.2.0-0.39.20170724git0387ee0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ed31e1f941
Comment 4 Fedora Update System 2017-07-28 20:53:11 EDT
freerdp-2.0.0-31.20170724gitf8c9f43.fc26, remmina-1.2.0-0.39.20170724git0387ee0.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4bc09c2364
Comment 5 Fedora Update System 2017-07-31 12:21:59 EDT
freerdp-2.0.0-31.20170724gitf8c9f43.fc26, remmina-1.2.0-0.39.20170724git0387ee0.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Jason Haar 2017-08-03 15:52:54 EDT
Hi there

I just upgraded to remmina-1.2.0-0.39.20170724git0387ee0.fc26 and instantly BROKE all my remmina profiles

Nothing worked - I couldn't SSH into anything. I think it lost access to ssh-agent (although I think that's actually gnome-agent these days?) as I use preshared keys for everything

I then "dnf downgrade remmina" and tried again and everything worked again.

So that's a really bad release

Jason
Comment 7 Fedora Update System 2017-08-07 17:21:39 EDT
freerdp-2.0.0-31.20170724gitf8c9f43.fc25, remmina-1.2.0-0.39.20170724git0387ee0.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Jason Haar 2017-08-07 17:34:43 EDT
Nope - still broken

The issue is with preshared keys. If I create a new SSH profile, it prompts for standard Unix password correctly. But if I set to "public key (automatic)" (as all my existing profiles are set to do), I get an error popup of "null"

It's like the last two releases have lost their ability to interact with the gnome-keyring-daemon?

Downgrading to remmina-1.2.0-0.35.20170510git41c8de6.fc26.x86_64 (which also downgrades all the plugins as dependencies) fixes it.
Comment 9 Pavel Alexeev 2018-01-05 13:11:39 EST
Hello Jason.

Please test update https://bodhi.fedoraproject.org/updates/FEDORA-2018-915a911681
Comment 10 Fedora Update System 2018-01-05 13:12:26 EST
remmina-1.2.0-0.44.rcgit.26.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-915a911681
Comment 11 Fedora Update System 2018-01-13 18:05:05 EST
remmina-1.2.0-0.44.rcgit.26.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.