Bug 1473976 - Calibre dependencies should be updated
Calibre dependencies should be updated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-22 18:45 EDT by Johannes Römer
Modified: 2017-07-24 16:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 16:36:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johannes Römer 2017-07-22 18:45:40 EDT
The SPEC file does not reflect the actual dependencies of current versions of Calibre. Some of them can be dropped to reduce the footprint of the installation.

Dependencies to be removed:
Requires: python-cherrypy -> not required since 3.0 [1]
Requires: python-genshi -> not required since 0.9.33 [2]
Requires: python-cssselect -> not required since 2.21.0 [3]

Calibre no longer ships embedded copies of cherrypy [1], cssutils [4], encutils (which is now part of cssutils) and trac. The following lines should therefore be removed (except for odf, which is still included and can be replaced by the external python2-odfpy package).
rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,encutils,cssutils}
rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac

I also noticed that the following line has no effect (the respective files do not include any \r\n style newlines) and should be removed as well.
sed -i 's/\r//' src/calibre/web/feeds/recipes/*

Judging from the official list of external applications used by Calibre [5], it might also be required to add some new packages to the SPEC file. But up to now I did not come across any errors because of missing dependencies.

[1] https://github.com/kovidgoyal/calibre/commit/5ed88a0bf596ea4389ac4fe08ccf249c7693d04d
[2] https://github.com/kovidgoyal/calibre/commit/276ec769f7d863ef5bd413387d9ea8312434e2db
[3] https://github.com/kovidgoyal/calibre/commit/97b8daee41ce47c385000003075107fb4f16fe3a
[4] https://github.com/kovidgoyal/calibre/commit/d4afa232cd93dc33f7d24712aa4f2dc7165bef72
[5] https://github.com/kovidgoyal/build-calibre/blob/master/scripts/sources.json
Comment 1 Kevin Fenzi 2017-07-24 16:36:13 EDT
Yep. Agreed with the changes and committed and built in rawhide. ;) 

Thanks!

https://koji.fedoraproject.org/koji/taskinfo?taskID=20716375

Note You need to log in before you can comment on or make changes to this bug.