Bug 1474064 - [Packaging] Please unbundle autopep8, pep8
[Packaging] Please unbundle autopep8, pep8
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse-pydev (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-23 10:22 EDT by Christian Stadelmann
Modified: 2017-07-24 05:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 05:07:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2017-07-23 10:22:04 EDT
Description of problem:


Version-Release number of selected component (if applicable):
eclipse-pydev-5.8.0-1.fc26.x86_64

How reproducible:
always (caused by packaging)

Steps to Reproduce:
1. Install eclipse-pydev

Actual results:
In /usr/lib64/eclipse/droplets/pydev-core/eclipse/plugins/org.python.pydev_5.5.0.201702281500/pysrc/third_party/pep8/autopep8.py, eclipse-pydev bundles the pep8.py and autopep8.py files

Expected results:
Do not bundle external libraries.

Additional info:
See the package guidelines https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#Bundling_and_Duplication_of_system_libraries
Comment 1 Mat Booth 2017-07-24 05:07:45 EDT
These files are symlinks to the system versions of the pep8 and autopep8 utilities:

[mbooth@fedora26 ~]$ ll /usr/lib/eclipse/droplets/pydev-core/eclipse/plugins/org.python.pydev_5.8.0.v20170616-0956/pysrc/third_party/pep8/
total 0
lrwxrwxrwx 1 root root 44 Jul  6 12:20 autopep8.py -> /usr/lib/python3.6/site-packages/autopep8.py
lrwxrwxrwx 1 root root 40 Jul  6 12:20 pep8.py -> /usr/lib/python3.6/site-packages/pep8.py

I don't believe there is anything more to be done to unbundle these tools, so I'm going to close this bug for now.

Note You need to log in before you can comment on or make changes to this bug.