Bug 1474088 - umounting USB storage freezing window
umounting USB storage freezing window
Status: CLOSED DUPLICATE of bug 1469789
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2017-07-23 15:46 EDT by Aleksandar Kostadinov
Modified: 2017-07-23 16:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-07-23 16:22:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 13729 None None None 2017-07-23 16:22 EDT

  None (edit)
Description Aleksandar Kostadinov 2017-07-23 15:46:47 EDT
Description of problem:
When ejecting USB storage, thunar's window freezes for some time. It can be moved around but you can't interact with it. It recovers after half a minute or something.

If I do `sudo eject /dev/sdd` in terminal the operation is performed immediately.

Version-Release number of selected component (if applicable):
Thunar 1.6.12 vs XFCE

How reproducible:

Steps to Reproduce:
1. mount USB drive
2. umount/eject from thunar

Actual results:
you need to wait a minute until you can use thunar

Expected results:
umount immediately

Additional info:
I tried on 2 computers that I just upgraded from fedora 24 to fedora 26. I followed all necessary steps to remove any outdated packages and everything else appears to be working fine.

Moreover no such issues I've seen with Fedora 24. Everything worked instantaneously there.
Comment 1 Aleksandar Kostadinov 2017-07-23 15:52:36 EDT
Or is this gvfs related?

Comment 2 Aleksandar Kostadinov 2017-07-23 15:56:43 EDT
I think this is a plain thunar-volman issue. When I umount a USB drive I see in xsession-errors:

> thunar-volman: Unsupported USB device type "usb".
> thunar-volman: Unsupported USB device type "usb-storage".
> thunar-volman: Unknown block device type "disk"

P.S. When I do `gio mount -e /run/media/avalon/E822-1FC9/` the device is ejected instantaneously.
Comment 3 Aleksandar Kostadinov 2017-07-23 16:22:54 EDT
Found this bug already reported in bug 1469789

Also upstream bug https://bugzilla.xfce.org/show_bug.cgi?id=13729

*** This bug has been marked as a duplicate of bug 1469789 ***

Note You need to log in before you can comment on or make changes to this bug.