Bug 147411 - anaconda fails to install grub for RAID-1 /boot
anaconda fails to install grub for RAID-1 /boot
Status: CLOSED DUPLICATE of bug 114690
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-07 17:02 EST by Ed Swierk
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Swierk 2005-02-07 17:02:36 EST
Description of problem:

anaconda fails to install grub on a newly-installed machine with its
/boot partition on a RAID-1 volume.

Steps to Reproduce:
1. Start the FC3 installer.  Set up a RAID-1 volume md0 on two
partitions (say, sda1 and sda2).  Create ext3 /boot on md0.
2. Use the default grub options, and complete the FC3 install.
3. Allow the machine to reboot.
  
Actual results:

grub does not start on boot; the system sits with a blank screen.

Expected results:

grub should start on boot.

Additional info:

As a workaround, you can start the system from the install CD in
rescue mode.  Use chroot /mnt/sysimage to mount the root partition.

Unfortunately, grub-install will not work (complains about md0 not
being a BIOS drive), so you must type the following commands directly
into grub:

   # grub
   > root (hd0,0)
   > setup (hd0)
   > quit

Then Ctrl-D to reboot.  grub should start normally at this point.
Comment 1 Peter Jones 2005-03-01 13:26:36 EST

*** This bug has been marked as a duplicate of 114690 ***
Comment 2 Hans Eric Sandström 2005-03-23 03:00:27 EST
(In reply to comment #0)
> Description of problem:
> anaconda fails to install grub on a newly-installed machine with its
> /boot partition on a RAID-1 volume.
> Steps to Reproduce:
> 1. Start the FC3 installer.  Set up a RAID-1 volume md0 on two
> partitions (say, sda1 and sda2).  Create ext3 /boot on md0.
> 2. Use the default grub options, and complete the FC3 install.
> 3. Allow the machine to reboot.
>   
> Actual results:
> grub does not start on boot; the system sits with a blank screen.
> Expected results:
> grub should start on boot.
> Additional info:
> As a workaround, you can start the system from the install CD in
> rescue mode.  Use chroot /mnt/sysimage to mount the root partition.
> Unfortunately, grub-install will not work (complains about md0 not
> being a BIOS drive), so you must type the following commands directly
> into grub:
>    # grub
>    > root (hd0,0)
>    > setup (hd0)
>    > quit
> Then Ctrl-D to reboot.  grub should start normally at this point.


Unfortunately the above procedure only installs the bootloader on one of the 
disks. So add this to the above:
>root (hd1,0)
>setup (hd1)
To setup boot loader on your second disk also.

Comment 3 Red Hat Bugzilla 2006-02-21 14:08:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.