Bug 1474171 - Build konqueror on all architectures
Build konqueror on all architectures
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: konqueror (Show other bugs)
rawhide
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On: 1474170
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 00:13 EDT by Yaakov Selkowitz
Modified: 2018-03-30 09:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: konqueror-17.12.3-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-30 09:12:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for rawhide (4.65 KB, patch)
2017-07-24 00:14 EDT, Yaakov Selkowitz
no flags Details | Diff
Rebased patch for rawhide (4.88 KB, patch)
2018-03-21 13:54 EDT, Yaakov Selkowitz
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 382643 None None None 2017-07-24 00:21 EDT

  None (edit)
Description Yaakov Selkowitz 2017-07-24 00:13:01 EDT
As only webenginepart actually uses QtWebEngine, with a minor patch to the build system, it is actually possible to use konqueror with khtmlpart (yeah, I know) or, even better, a KF5-based version of kwebkitpart (see bug 1474170).
Comment 1 Yaakov Selkowitz 2017-07-24 00:14 EDT
Created attachment 1303426 [details]
Patch for rawhide

Scratch build on all arches:

https://koji.fedoraproject.org/koji/taskinfo?taskID=20707457
Comment 2 Rex Dieter 2017-11-09 15:26:32 EST
I'm ok with the proposed changed here, minus the kwebkitpart dependency (we'll need to handle that differently and separate I think)

Or, we can wait for kwebkitpart to get sorted out and do it all at once.
Comment 3 Yaakov Selkowitz 2017-11-09 18:32:34 EST
(In reply to Rex Dieter from comment #2)
> I'm ok with the proposed changed here, minus the kwebkitpart dependency
> (we'll need to handle that differently and separate I think)
> 
> Or, we can wait for kwebkitpart to get sorted out and do it all at once.

Mixed feelings on this.  Technically konqueror still functions fine as an all-in-one file manager/viewer/editor with the other KParts (dolphinpart, katepart, okularpart, oktetapart, etc.).  OTOH as a web browser it is only minimally usable with only khtmlpart; most modern websites won't display properly with it.

However, the thought just occurred to me that, in whatever order we do this, perhaps the webenginepart should be a separate subpackage (which would be Recommended or Required by the konqueror package on %qt5_qtwebengine_arches).

Let me know your thoughts on these points and I can respin the patch.
Comment 4 Yaakov Selkowitz 2018-03-21 13:34:27 EDT
Now that kwebkitpart is updated to KF5, how do you want to proceed with this?

1) Separate subpackage for kwebenginepart?
2) Hard or soft dep on kwebkitpart (or kwebenginepart if yes above) depending on arch?
Comment 5 Rex Dieter 2018-03-21 13:39:17 EDT
I think option 2 seems preferable for now.
Comment 6 Rex Dieter 2018-03-21 13:42:17 EDT
Looks like will require some patching, konqueror's buildsystem currently considers webengine an required, non-optional, component.
Comment 7 Yaakov Selkowitz 2018-03-21 13:43:17 EDT
That's already part of my patch; I'm rebasing it now for 17.12.3.
Comment 8 Yaakov Selkowitz 2018-03-21 13:54 EDT
Created attachment 1411290 [details]
Rebased patch for rawhide

Scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=25863006
Comment 9 Rex Dieter 2018-03-21 15:59:48 EDT
Thanks, opted for both afterall, may be useful beyond just konqueror.

%changelog
* Wed Mar 21 2018 Rex Dieter <rdieter@fedoraproject.org> - 17.12.3-2
- make buildable on all archs (#1474171)
- -kwebenginepart subpkg
Comment 10 Fedora Update System 2018-03-21 16:37:18 EDT
konqueror-17.12.3-2.fc28 kwebkitpart-1.4.0-0.1.20180320.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-78b5d65ff2
Comment 11 Fedora Update System 2018-03-22 10:12:58 EDT
konqueror-17.12.3-2.fc28, kwebkitpart-1.4.0-0.1.20180320.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-78b5d65ff2
Comment 12 Fedora Update System 2018-03-30 09:12:40 EDT
konqueror-17.12.3-2.fc28, kwebkitpart-1.4.0-0.1.20180320.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.