Bug 1474188 - kernel/tcmu-runner: fix uio_poll crash during uio device removal
kernel/tcmu-runner: fix uio_poll crash during uio device removal
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tcmu-runner (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.3.0
Assigned To: Prasanna Kumar Kalever
Sweta Anandpara
:
Depends On: 1465619 1473162
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-07-24 01:49 EDT by Prasanna Kumar Kalever
Modified: 2017-09-21 00:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: tcmu-runner-1.2.0-11.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1465619
Environment:
Last Closed: 2017-09-21 00:20:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 7 Sweta Anandpara 2017-08-03 07:07:58 EDT
Having discussed it with Prasanna, it will be difficult to hit this code path with the fix for uio_read() not yet in.

Hence, will be verifying this bug only after bz 1473162 is fixed.
Comment 8 krishnaram Karthick 2017-09-18 22:30:06 EDT
This issue is not seen at CNS (builds above cns-deploy-5.0.0-38.el7rhgs.x86_64). i.e., tcmu-runner-1.2.0-14.el7rhgs.x86_64

Logging and metrics using gluster block in ocp environment is up for close to 4 week now without any issues.
Comment 9 krishnaram Karthick 2017-09-19 01:21:17 EDT
(In reply to krishnaram Karthick from comment #8)
> This issue is not seen at CNS (builds above
> cns-deploy-5.0.0-38.el7rhgs.x86_64). i.e.,
> tcmu-runner-1.2.0-14.el7rhgs.x86_64
> 
> Logging and metrics using gluster block in ocp environment is up for close
> to 4 week now without any issues.

Please ignore this comment. This comment was not meant for this bug.
Comment 10 Sweta Anandpara 2017-09-19 06:40:52 EDT
Tested and verified this on the build tcmu-runner-1.2.0-15 and gluster-block-0.2.1-13 and gluster-3.8.4-44

Multiple block creates and deletes were given in parallel and in a sequence from different peer nodes, on a 2*3 volume. No crash (mentioned in description) was seen, this time or multiple other times that block deletes have been executed.

Moving this to verified in rhgs 3.3.0.
Comment 12 errata-xmlrpc 2017-09-21 00:20:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2773

Note You need to log in before you can comment on or make changes to this bug.