Bug 1474190 - cassandra fails on gluster-block with both replicate and ec volumes
cassandra fails on gluster-block with both replicate and ec volumes
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks: 1476653
  Show dependency treegraph
 
Reported: 2017-07-24 02:00 EDT by Pranith Kumar K
Modified: 2017-12-08 12:35 EST (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1476653 (view as bug list)
Environment:
Last Closed: 2017-12-08 12:35:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2017-07-24 02:00:56 EDT
Description of problem:
gluster-block file is opened with O_DIRECT but because block-profile has filter_O_DIRECT enabled, it is leading to high latency for fsync which leads to failures in cassandra. Disabling remote-dio fixed this issue. We need to change remote-dio to disabled in gluster-block.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-07-24 02:25:45 EDT
REVIEW: https://review.gluster.org/17856 (extras: Disable remote-dio in gluster-block profile) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Worker Ant 2017-07-24 10:17:14 EDT
COMMIT: https://review.gluster.org/17856 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 0b3fec6924cad5c9f38941550ab4106972efa5cc
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jul 24 11:31:56 2017 +0530

    extras: Disable remote-dio in gluster-block profile
    
    gluster-block file is opened with O_DIRECT but because block-profile has
    remote-dio enabled, it is leading to high latency for fsync which leads to
    failures in cassandra. Disabling remote-dio fixed this issue. We need to change
    remote-dio to disabled in gluster-block.
    
    BUG: 1474190
    Change-Id: Ifd845ea9cbdcc08dd6073faca6082682af376ca3
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/17856
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Shyamsundar 2017-12-08 12:35:17 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.