Bug 1474238 - Cannot navigate filter pages for role via Hammer
Cannot navigate filter pages for role via Hammer
Status: CLOSED DUPLICATE of bug 1428516
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.2.11
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 04:13 EDT by Sanket Jagtap
Modified: 2017-08-07 09:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 09:57:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sanket Jagtap 2017-07-24 04:13:16 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Satellite 6.2.11 snap1
rpm -qa | grep satellite
satellite-6.2.11-1.0.el7sat.noarch
tfm-rubygem-foreman_theme_satellite-0.1.46-1.el7sat.noarch
satellite-installer-6.2.0.13-1.el7sat.noarch
satellite-cli-6.2.11-1.0.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1.Create a role
2.Assign various permissions to the role
3.Try to view those perms, filters via CLI Hammer

Actual results:
hammer> role filters --name bug_role_ak --page=1
----|------------------------|--------|------------|-------------|----------------------------
ID  | RESOURCE TYPE          | SEARCH | UNLIMITED? | ROLE        | PERMISSIONS
----|------------------------|--------|------------|-------------|----------------------------
234 | Katello::ActivationKey | none   | no         | bug_role_ak | view_activation_keys
235 | Katello::ContentView   | none   | no         | bug_role_ak | view_content_views
236 | Katello::Product       | none   | no         | bug_role_ak | view_products
237 | Katello::KTEnvironment | none   | no         | bug_role_ak | view_lifecycle_environments
.......
......
----|------------------------|--------|------------|-------------|----------------------------
Page 1 of 4 (use --page and --per-page for navigation)

hammer> role filters --name bug_role_ak --page=2
----|------------------------|--------|------------|-------------|----------------------------
ID  | RESOURCE TYPE          | SEARCH | UNLIMITED? | ROLE        | PERMISSIONS
----|------------------------|--------|------------|-------------|----------------------------
234 | Katello::ActivationKey | none   | no         | bug_role_ak | view_activation_keys
235 | Katello::ContentView   | none   | no         | bug_role_ak | view_content_views
236 | Katello::Product       | none   | no         | bug_role_ak | view_products
237 | Katello::KTEnvironment | none   | no         | bug_role_ak | view_lifecycle_environments
.....
....
----|------------------------|--------|------------|-------------|----------------------------
Page 1 of 4 (use --page and --per-page for navigation)

Also , tried with per-page option, no luck the result is same with count 20

hammer> role filters --name bug_role_ak --per-page=35
----|------------------------|--------|------------|-------------|----------------------------
ID  | RESOURCE TYPE          | SEARCH | UNLIMITED? | ROLE        | PERMISSIONS
----|------------------------|--------|------------|-------------|----------------------------
234 | Katello::ActivationKey | none   | no         | bug_role_ak | view_activation_keys
235 | Katello::ContentView   | none   | no         | bug_role_ak | view_content_views
236 | Katello::Product       | none   | no         | bug_role_ak | view_products
237 | Katello::KTEnvironment | none   | no         | bug_role_ak | view_lifecycle_environments
......
......
----|------------------------|--------|------------|-------------|----------------------------
Page 1 of 4 (use --page and --per-page for navigation)


Expected results:
The pages should be navigated.

Additional info:
Comment 3 Marek Hulan 2017-08-04 09:57:52 EDT
I believe this is a duplicate of BZ 1428516 which has been already verified by QE. Please reopen if I misunderstood the request.

*** This bug has been marked as a duplicate of bug 1428516 ***

Note You need to log in before you can comment on or make changes to this bug.