Bug 1474259 - router creation permission issue - 'neutron router-create' vs 'openstack router create' - inconsistent for _member_ role
router creation permission issue - 'neutron router-create' vs 'openstack rout...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient (Show other bugs)
10.0 (Newton)
All Linux
medium Severity low
: z5
: 10.0 (Newton)
Assigned To: anil venkata
Toni Freger
: Triaged, ZStream
Depends On: 1400917
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 05:06 EDT by anil venkata
Modified: 2017-09-28 12:37 EDT (History)
14 users (show)

See Also:
Fixed In Version: python-openstackclient-3.2.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
When "router_distributed=True" is set in the neutron.conf file, an administrator cannot override this setting with the "--distributed" flag. The administrator cannot create a non-distributed router. This fix allows centralized and distributed flags during router creation. An administrator can now create distributed and non-distributed routers through CLI flags.
Story Points: ---
Clone Of: 1400917
Environment:
Last Closed: 2017-09-28 12:37:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1664255 None None None 2017-07-24 05:06 EDT
Red Hat Knowledge Base (Solution) 2791251 None None None 2017-07-24 05:06 EDT

  None (edit)
Comment 2 anil venkata 2017-08-10 07:21:25 EDT
Build python-openstackclient-3.2.1-2.el7ost created with the fix.

Thanks
Anil
Comment 11 errata-xmlrpc 2017-09-28 12:37:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2824

Note You need to log in before you can comment on or make changes to this bug.