Bug 1474314 - [Yalta] Doc RFE: [Doc -Deploy Guide] Document how to deploy the undercloud
[Yalta] Doc RFE: [Doc -Deploy Guide] Document how to deploy the undercloud
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 3.0
Assigned To: Aron Gunn
ceph-qe-bugs
Rachana Patel
: Documentation, FutureFeature
Depends On:
Blocks: 1474058
  Show dependency treegraph
 
Reported: 2017-07-24 08:01 EDT by Anjana Suparna Sriram
Modified: 2017-12-25 22:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-25 22:40:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Rachana Patel 2017-11-06 02:27:11 EST
suggestion:-

A) 
Doc
===
section 4.b - 'Lookup the valid Pool ID for the RHOSP entitlement:'

suggestion
==========
Please update example with proper example.
i.e. 
[stack@director ~]$ sudo subscription-manager list --available --all --matches="*OpenStack*"

here user should look for word that matches to our pool name
- Example output says 'Name of SKU' - replace it with SKU name that user will be seeing

(I am not sure about what should be value for 'Name of SKU', Joan or Neil or Eddie can provide you result



Changes required
================

1) Procedure: Installing the Red Hat OpenStack Platform Director' - > step 6.b ask to set value

inspection_extras - false
inspection_runbench - true
inspection_enable_uefi - false

issue
=====
When I set value as per doc it fails and give error

[stack@b10-h29-r620 ~]$ openstack undercloud install
Logging to /home/stack/.instack/install-undercloud.log
Checking for a FQDN hostname...
Static hostname detected as b10-h29-r620.rdu.openstack.engineering.redhat.com
Transient hostname detected as b10-h29-r620.rdu.openstack.engineering.redhat.com
Added hostname b10-h29-r620.rdu.openstack.engineering.redhat.com to /etc/hosts
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1239, in install
    instack_env = _generate_environment(instack_root)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 899, in _generate_environment
    raise RuntimeError('inspection_extras must be enabled for '
RuntimeError: inspection_extras must be enabled for inspection_runbench to work
Command 'instack-install-undercloud' returned non-zero exit status 1

solution
========
it works for me if I set values

inspection_extras - true
inspection_runbench - false
inspection_enable_uefi - true



2)  'Procedure: Installing the Red Hat OpenStack Platform Director' -> 6.b

we also need to edit 'undercloud_hostname' in '~/undercloud.conf'  else we might face failures in few scenario


3) 'Procedure: Installing the Red Hat OpenStack Platform Director'-> step 8.c
Verify the DNS server by viewing the subnet:

[stack@director ~]$ openstack subnet show

issue
======
Command gives error as below so please modify command

[stack@refarch-r630-02 images]$ openstack subnet show
usage: openstack subnet show [-h] [-f {json,shell,table,value,yaml}]
                             [-c COLUMN] [--max-width <integer>] [--noindent]
                             [--prefix PREFIX]
                             <subnet>
openstack subnet show: error: too few arguments

(I am not sure what it should be so please ask someone from OSP engg team.



4)  'Registering and Introspecting the Hardware' - 
1.b
$NODE_ROLE-INSTANCE_NUM with the node’s role, along with a node number. This solution uses two roles: controller and osd-compute.

if we set role to 'controller' we need to make other changes to make it work(e.g. modify flavor and other config) so better to set it to 'control'
e.g.  "capabilities": "node:control-0,boot_option:local"

For me it never worked with 'control'.

if we set it to control then also modify 'Procedure: Configuring a Overcloud Node Layout' -> step 2.d

replace 
'  ControllerSchedulerHints:
    'capabilities:node': 'controller-%index%'' 
with
  ControllerSchedulerHints:
    'capabilities:node': 'control-%index%'


5)
Comment 6 Rachana Patel 2017-11-08 17:00:06 EST
point 1-5 mentioned in comments 4 are fixed.

Please move back to ON_QA  with link of doc when suggestion A) is fixed

Note You need to log in before you can comment on or make changes to this bug.