Bug 1474345 - update of spacewalk-remote-utils with RHEL 7.4 channel definitions
update of spacewalk-remote-utils with RHEL 7.4 channel definitions
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
580
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Martin Korbel
:
Depends On:
Blocks: sat58-errata
  Show dependency treegraph
 
Reported: 2017-07-24 08:34 EDT by Michael Mráka
Modified: 2017-08-15 09:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-remote-utils-2.5.1-9-sat
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 09:27:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2474 normal SHIPPED_LIVE Red Hat Network Tools spacewalk-remote-utils bug fix and enhancement update 2017-08-15 13:26:58 EDT

  None (edit)
Description Michael Mráka 2017-07-24 08:34:31 EDT
Description of problem:
After RHEL 7.4 GA update spacewalk-remote-utils with RHEL 7.4 channel definitions.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michael Mráka 2017-08-03 04:12:32 EDT
Added in upstream spacewalk git by
commit 6157f191b3aa1a5f13780035874a31e31fbab9f7
    1474345 - update spacewalk-remote-utils with RHEL 7.4 channel definitions
Comment 3 Michael Mráka 2017-08-03 04:45:09 EDT
cBackported to SATELLITE-5.8 
ommit 57295bad1fcdc9ce10680d89b7d15132ea22c46a
    1474345 - update spacewalk-remote-utils with RHEL 7.4 channel definitions
Comment 4 Pavel Studeník 2017-08-04 07:51:55 EDT
>> spacewalk-create-channel -l ... -s ... -v 6 -r erver -u u9 -a x86_64 -d  channel-6.9

You have not specified a source channel, we will try to determine it from inputs
Trying with source channel: rhel-x86_64-server-6
Reusing channel-6.9 as destination channel
3854 packages in source file to push.
Pushing 3854 packages, please wait.
....
('3550 of 3854', None)
(' \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r', None)
('3600 of 3854', None)
(' \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r', None)
('3650 of 3854', None)
(' \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r', None)
('3700 of 3854', None)
(' \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r', None)
('3750 of 3854', None)
(' \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r', None)
('3800 of 3854', None)
(' \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r', None)
('3850 of 3854', None)
(' \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r \r', None)
Successfully pushed 3854 packages out of 3854


It looks that output is printed incorrectly on RHEL 6.9 and RHEL 7.4
Comment 5 Pavel Studeník 2017-08-04 08:19:02 EDT
Problems with output are in following constructions:

>> print('%d of %d' % (pack_num-len(ids_to_add), pack_num), sys.stdout.flush())

>> print('%s\r' % ' '*20, sys.stdout.flush())
Comment 6 Pavel Studeník 2017-08-04 08:39:22 EDT
fix https://github.com/spacewalkproject/spacewalk/pull/563
Comment 7 Michael Mráka 2017-08-04 09:28:42 EDT
Output fixed in spacewalk git by
commit 948a5af471386bcf5da6d9b9bc8df913959f6794
    1474345 - fixed script output
Comment 8 Michael Mráka 2017-08-04 09:32:03 EDT
Backported to SATELLITE-5.8 as
commit 2483660132a52f71cfdc81ac9a323689cf518ddc
    1474345 - fixed script output
Comment 10 Martin Korbel 2017-08-09 04:36:08 EDT
VERIFIED on spacewalk-remote-utils-2.5.1-9

> rpm -ql spacewalk-remote-utils | grep 7-u4
/usr/share/rhn/channel-data/7-u4-client-x86_64
/usr/share/rhn/channel-data/7-u4-client-x86_64-Optional
/usr/share/rhn/channel-data/7-u4-client-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u4-computenode-x86_64
/usr/share/rhn/channel-data/7-u4-computenode-x86_64-Optional
/usr/share/rhn/channel-data/7-u4-computenode-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u4-server-ppc64
/usr/share/rhn/channel-data/7-u4-server-ppc64-Optional
/usr/share/rhn/channel-data/7-u4-server-ppc64-Supplementary
/usr/share/rhn/channel-data/7-u4-server-s390x
/usr/share/rhn/channel-data/7-u4-server-s390x-Highavailability
/usr/share/rhn/channel-data/7-u4-server-s390x-Optional
/usr/share/rhn/channel-data/7-u4-server-s390x-Resilientstorage
/usr/share/rhn/channel-data/7-u4-server-s390x-Supplementary
/usr/share/rhn/channel-data/7-u4-server-x86_64
/usr/share/rhn/channel-data/7-u4-server-x86_64-Highavailability
/usr/share/rhn/channel-data/7-u4-server-x86_64-Optional
/usr/share/rhn/channel-data/7-u4-server-x86_64-Resilientstorage
/usr/share/rhn/channel-data/7-u4-server-x86_64-Supplementary
/usr/share/rhn/channel-data/7-u4-workstation-x86_64
/usr/share/rhn/channel-data/7-u4-workstation-x86_64-Optional
/usr/share/rhn/channel-data/7-u4-workstation-x86_64-Supplementary


> spacewalk-create-channel -l admin -s satellite.redhat.com -v 6 -r server -u u9 -a x86_64 -d mk-channel-6.9
Password: 
You have not specified a source channel, we will try to determine it from inputs
Trying with source channel: rhel-x86_64-server-6
Creating channel, mk-channel-6.9, with arch x86_64
3854 packages in source file to push.
Successfully pushed 3854 packages out of 3854


> spacewalk-create-channel -l admin -s satellite.redhat.com -v 7 -r server -u u4 -a x86_64 -d mk-channel-7.4
Password: 
You have not specified a source channel, we will try to determine it from inputs
Trying with source channel: rhel-x86_64-server-7
Creating channel, mk-channel-7.4, with arch x86_64
4986 packages in source file to push.
Pushing 4882 packages, please wait.
Successfully pushed 4882 packages out of 4986
Comment 12 errata-xmlrpc 2017-08-15 09:27:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2474

Note You need to log in before you can comment on or make changes to this bug.