Bug 1474392 - Review Request: perl-Test-Exec - Test that some code calls exec without terminating testing
Review Request: perl-Test-Exec - Test that some code calls exec without termi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1474425
  Show dependency treegraph
 
Reported: 2017-07-24 09:56 EDT by Petr Pisar
Modified: 2017-08-01 08:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Test-Exec-0.04-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 08:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jplesnik: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2017-07-24 09:56:15 EDT
Spec URL: https://ppisar.fedorapeople.org/perl-Test-Exec/perl-Test-Exec.spec
SRPM URL: https://ppisar.fedorapeople.org/perl-Test-Exec/perl-Test-Exec-0.04-1.fc27.src.rpm
Description:
The Test::Exec Perl module provides the most simple possible tools for testing
code that might call exec function, which would otherwise end your test by
calling another program. This code should detect and capture exec calls, even
if they are inside an eval statement.

Fedora Account System Username: ppisar
Comment 1 Jitka Plesnikova 2017-07-31 10:55:48 EDT
Source file is ok
Summary is ok
License is ok
Description is ok
URL and Source0 are ok
All tests passed

BuildRequires are almost ok
FIX: Please add build-requires 'make'

$ rpm -qp --requires perl-Test-Exec-0.04-1.fc27.noarch.rpm | sort | uniq -c
      1 perl(base)
      1 perl(Exporter)
      1 perl(:MODULE_COMPAT_5.26.0)
      1 perl(Return::MultiLevel)
      1 perl(strict)
      1 perl(Test2::API) >= 1.302015
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
Binary requires are Ok.

$ rpm -qp --provides perl-Test-Exec-0.04-1.fc27.noarch.rpm | sort | uniq -c
      1 perl(Test::Exec) = 0.04
      1 perl-Test-Exec = 0.04-1.fc27
Binary provides are Ok.

$ rpmlint ./perl-Test-Exec*
perl-Test-Exec.noarch: W: spelling-error %description -l en_US eval -> veal, vela, val
perl-Test-Exec.src: W: spelling-error %description -l en_US eval -> veal, vela, val
2 packages and 1 specfiles checked; 0 errors, 2 warnings. 
Rpmlint is ok

Please correct 'FIX' issue.

Otherwise the package looks good.
Approved.
Comment 2 Gwyn Ciesla 2017-08-01 08:23:48 EDT
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/perl-Test-Exec
Comment 3 Petr Pisar 2017-08-01 08:54:30 EDT
Thank you for the review and the repository. I added the dependency on make.

Note You need to log in before you can comment on or make changes to this bug.