Bug 1474406 - openstack_gnocchi support for sosreport on RHEL-7.3 [NEEDINFO]
openstack_gnocchi support for sosreport on RHEL-7.3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Pavel Moravec
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 10:19 EDT by Sachin
Modified: 2017-08-31 12:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-31 12:00:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pmoravec: needinfo? (sacpatil)


Attachments (Terms of Use)

  None (edit)
Description Sachin 2017-07-24 10:19:43 EDT
Description of problem:

sos-3.4[1] has gnocchi plugin to collect configurations and logs of Gnocchi. Can we have it merged in RHEL-7.3 for Red Hat OpenStack 10 and Red Hat OpenStack 11  

Version-Release number of selected component (if applicable):
sos-3.3-5.el7_3.noarch


How reproducible:
NA

Steps to Reproduce:
No reproducing steps required.
 
Actual results:


Expected results:


Additional info:
Similar request is for Aodh configurations and logs[2]


[1] https://github.com/sosreport/sos/releases/tag/3.4
[2] https://github.com/sosreport/sos/pull/1050
Comment 2 Pavel Moravec 2017-07-24 10:36:58 EDT
Sachin,
Do you request 7.4 inclusion (per flags raised) or RHEL7.3 z-stream request?

For the 1st option: gnocchi plugin will be in RHEL 7.4 by default, since we rebase sos to 3.4 in RHEL 7.4.

For the 2nd option (7.3 z-stream), please:
- add Layered Product: OpenStack
- give a proper business justification for the Zstream (different release schedules in RHEL and OSP, customer impact when plugin missing)
- state that the change is exposed to OSP only (I can confirm so)
Comment 3 Pavel Moravec 2017-08-31 12:00:02 EDT
This bugzilla has been fixed in RHEL7.4. My understanding is no 7.3 z-stream is required, so closing the BZ.

Note You need to log in before you can comment on or make changes to this bug.