Bug 1474408 - After Docker restart pod is failing with 'Transport endpoint is not connected'
After Docker restart pod is failing with 'Transport endpoint is not connected'
Status: CLOSED DUPLICATE of bug 1424680
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bradley Childs
Jianwei Hou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 10:25 EDT by Vladislav Walek
Modified: 2017-07-25 09:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 09:28:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladislav Walek 2017-07-24 10:25:17 EDT
Description of problem:

With gluster persistent volume. 
If the docker daemon service is restarted, then the pod is failing with error "Transport endpoint is not connected".
The get it fixed, the deployment must be redeployed and new pods are created, then the volume is reconnected.

Version-Release number of selected component (if applicable):
OpenShift Container Platform 3.4

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:
Comment 3 Eric Paris 2017-07-25 09:28:24 EDT

*** This bug has been marked as a duplicate of bug 1424680 ***

Note You need to log in before you can comment on or make changes to this bug.