Bug 1474409 - Pinned VM cannot be started after soft fencing
Pinned VM cannot be started after soft fencing
Status: CLOSED DUPLICATE of bug 1474320
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
4.1.4.2
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: nobody nobody
meital avital
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 10:27 EDT by Petr Matyáš
Modified: 2017-07-25 01:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 01:32:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (805.65 KB, application/x-gzip)
2017-07-24 10:27 EDT, Petr Matyáš
no flags Details

  None (edit)
Description Petr Matyáš 2017-07-24 10:27:08 EDT
Created attachment 1303696 [details]
logs

Description of problem:
When I start a VM that's pinned (set as start on specific host in host tab in edit VM dialogue) to some host and then after it is started, vdsmd service on that host gets stopped, soft fencing is applied. However after that the VM is paused and cannot be started.

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.4.2-0.1.el7.noarch
vdsm-4.19.23-1.el7ev.x86_64

How reproducible:
always

Steps to Reproduce:
1. start a VM that's pinned to some host
2. kill vdsmd service on that host
3. check VM state after soft fencing finishes

Actual results:
VM is paused and cannot be started

Expected results:
VM is up and running

Additional info:
Jul 24, 2017 4:18:56 PM
Failed to resume VM rreret (Host: slot-11, User: admin@internal-authz).
Jul 24, 2017 4:18:56 PM
VDSM slot-11 command ResumeBrokerVDS failed: VM u'272ce244-e4e8-409f-bb1c-fa1ba75b88f4' was not started yet or was shut down
Comment 1 Michal Skrivanek 2017-07-25 01:32:51 EDT
same thing as bug 1474320

*** This bug has been marked as a duplicate of bug 1474320 ***

Note You need to log in before you can comment on or make changes to this bug.