Bug 1474414 - git-core no longer includes support for gnome-keyring integration
git-core no longer includes support for gnome-keyring integration
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
26
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: pstodulk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 10:42 EDT by Jim Perrin
Modified: 2017-07-31 13:30 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 11:55:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Perrin 2017-07-24 10:42:48 EDT
Description of problem:
In Fedora 25, gnome-keyring could be used as a credential store for git, containing /usr/libexec/git-core/git-credential-gnome-keyring. In F26, this is no longer the case. 

Version-Release number of selected component (if applicable):
git-core-2.13.3-1.fc26.x86_64

How reproducible:
always

Steps to Reproduce:
1. On F25, follow http://blog.scottlowe.org/2016/11/23/gnome-keyring-git-credential-fedora/ to configure.
2. upgrade to f26
3. git can no longer use gnome-keyring, as the integration file is no longer there (/usr/libexec/git-core/git-credential-gnome-keyring)
4. rpm -ql git-core to verify that the git-credential-gnome-keyring file is indeed missing. 

Actual results:
git throws credential errors because the integration no longer exists.

Expected results:
git continues to use gnome-keyring to store credentials. 

Additional info:
Comment 1 Todd Zullinger 2017-07-24 11:43:35 EDT
The libgnome-keyring which the gnome-keyring helper used is deprecated by the upstream Gnome community.  The replacement library is libsecret, which supports Gnome keyring as well as other implementations using the XDG Secret Service API.

There is a libsecret credential helper installed for this use:

    /usr/libexec/git-core/git-credential-libsecret

This was added in upstream git in https://github.com/git/git/commit/87d1353a6a (Oct 2016) and in the fedora git package in https://src.fedoraproject.org/cgit/rpms/git.git/commit/?id=01e0c73c8 (Feb 2017).
Comment 2 Jim Perrin 2017-07-24 11:55:00 EDT
Ah, I see. thanks for the pointers.

Note You need to log in before you can comment on or make changes to this bug.