Bug 147442 - CAN-2005-0227 Multiple security issues in PostgreSQL (CAN-2005-0244 CAN-2005-0245 CAN-2005-0246 CAN-2005-0247)
Summary: CAN-2005-0227 Multiple security issues in PostgreSQL (CAN-2005-0244 CAN-2005-...
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rh-postgresql
Version: 3.0
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Tom Lane
QA Contact:
Keywords: Security
Depends On:
TreeView+ depends on / blocked
Reported: 2005-02-07 22:54 UTC by Tom Lane
Modified: 2013-07-03 03:03 UTC (History)
1 user (show)

Clone Of:
Last Closed: 2005-02-14 09:46:59 UTC

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2005:141 high SHIPPED_LIVE Important: rh-postgresql security update 2005-02-14 05:00:00 UTC

Description Tom Lane 2005-02-07 22:54:58 UTC
Description of problem:
CAN-2005-0227 and other issues:
LOAD command allows unprivileged local database users to cause server
to execute arbitrary code.
CREATE AGGREGATE bypasses check for EXECUTE permission on functions.
Buffer overrun in plpgsql parser.
Potential crashes in various contrib modules.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. See upstream bug reports.
Actual results:

Expected results:

Additional info:
Intended fix is to update to PostgreSQL 7.3.9-1, which fixes these issues
as well as a couple of non-security-related bugs.

The same issues need to be fixed in postgresql for AS2.1; however
the upstream community has not produced patches for postgres 7.1. 

The vulnerabilities are already public, so no need for embargo.

Comment 1 Mark J. Cox 2005-02-09 09:31:45 UTC
A permission checking flaw in PostgreSQL was discovered.  A local user
could bypass the EXECUTE permission check for functions by using the
CREATE AGGREGATE command.  The Common Vulnerabilities and Exposures
project (cve.mitre.org) has assigned the name CAN-2005-0244 to this issue.

Multiple buffer overflows were found in PL/PgSQL.  A database user who
has permissions to create plpgsql functions could trigger this flaw
which could lead to arbitrary code execution, gaining the privileges
of the PostgreSQL server. The Common Vulnerabilities and Exposures
project (cve.mitre.org) has assigned the names CAN-2005-0245 and
CAN-2005-0247 to these issues.

A flaw in the integer aggregator (intagg) contrib module for
PostgreSQL was found.  A user could create carefully crafted arrays
and cause a denial of service (crash).  The Common Vulnerabilities and
Exposures project (cve.mitre.org) has assigned the name CAN-2005-0246
to this issue.

Comment 2 Tom Lane 2005-02-10 18:31:38 UTC
I've filed a separate bug #147703 for the AS2.1 branch.

Comment 3 Mark J. Cox 2005-02-14 09:46:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.