Bug 1474423 - akmods to install the appropriate kernel-devel variant
Summary: akmods to install the appropriate kernel-devel variant
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: akmods
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-24 15:00 UTC by Nicolas Chauvet (kwizart)
Modified: 2017-08-20 17:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-12 22:03:06 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1228897 None NEW dnf installs the wrong kernel variant subpackages 2019-09-05 17:22:13 UTC

Internal Links: 1228897

Description Nicolas Chauvet (kwizart) 2017-07-24 15:00:26 UTC
Description of problem:
when installing any kernel-devel-uname-r, the appropriate variant should be picked.

Version-Release number of selected component (if applicable):
current

How reproducible:
always

Steps to Reproduce:
1. dnf install kernel-devel-uname-r
2. when using kernel-lpae (on arm) or kernel-debug
3.

Actual results:
the default kernel-devel is installed no matter which kernel variant is used.

Expected results:
It should install the same variant as the kernel

Additional info:
Suggested implementation. Please note that akmods or else are noarch packages, so they should not have %ifarch in them.
Also this is change cannot be implemented yet because the packaging guideline currently prevent wide use of boolean dependencies.

---
Requires: kernel-devel-uname-r
%if 0{?fedora:
Suggests: (kernel-devel if kernel)
Suggests: (kernel-debug-devel if kernel-debug)
Suggests: (kernel-PAE-devel if kernel-PAE)
Suggests: (kernel-PAEdebug-devel if kernel-PAEdebug)
Suggests: (kernel-lpae-devel if kernel-lpae)
Suggests: (kernel-rt-devel if kernel-rt)
}
---

Comment 1 Nicolas Chauvet (kwizart) 2017-08-12 22:03:06 UTC
Fixed in akmods-0.5.6-10


Note You need to log in before you can comment on or make changes to this bug.